Caractères accentués

Bonjour.
Lorsque j'encode un caractère accentué, par exemple "très modéré" au-dessus de la portée j'obtiens un message d'erreur UTF-8 inconnu ... Comment faire pour que Lilypond reconnaisse les caractères accentués français . Je cherche dans la documentation mais tourne en rond. Il faudrait adapter le code page. Je ne sais si c'est dans la définition des plugins de Jedit ou dans Lilypond directement.
Merci de l'aide
Daniel Bernair

Rue de Namur, 3
7130 Battignies (Binche)
064/36.64.93
0496/07.60.45

Normalement c'est dans jEdit :
Utilitaires > Options générales > Encodages > Encodage de caractères par défaut
Mais c'est possible que cela ne vienne pas de là. En tout cas, LilyPond n'est pas la cause, c'est uniquement l'encodage du fichier.

Bertrand

Bonjour,

LilyPond accepte sans souci les caractères Unicode. S'il y a une erreur,
c'est à mon avis plutôt lié à l'éditeur. J'ai parfois eu des soucis avec
JEdit au début (le temps de trouver la configuration à ce sujet).

Il y a peut-être d'autres possibilités, mais je doute que le problème vienne
de LilyPond (qui accepte les accents en français ou du hangeul coréen dans
la même phrase).

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Caracteres-accentues-tp6587484p6587759.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Bonjour,

il s'agit de configurer l'encodage de jEdit. En bas à droite de la
fenêtre, vous devez avoir une indication du style "(text, lilypond,
Cp-1252)" ou autre. Double-cliquez dessus et sélectionnez UTF-8 dans
la liste des encodages (Il est également possible de choisir l'UTF-8
par défaut dans les Préférences Globales, section Encodings, mais cela
ne changera pas vos fichiers déjà existant).

Bon courage !

Cordialement,
V. Villenave.

···

2011/7/15 Daniel Bernair <****@****>:

Bonjour.
Lorsque j'encode un caractère accentué, par exemple "très modéré" au-dessus
de la portée j'obtiens un message d'erreur UTF-8 inconnu ... Comment faire
pour que Lilypond reconnaisse les caractères accentués français . Je cherche
dans la documentation mais tourne en rond. Il faudrait adapter le code page.
Je ne sais si c'est dans la définition des plugins de Jedit ou dans Lilypond
directement.

J'ai suivi également le conseil de Valentin Villenave, à savoir le conseil que vous donnez en sélectionnant UTF-8, cela semble fonctionner.
Amicalement
Daniel Bernair

···

----- Original Message -----

From: Bertrand Bordage
To: Daniel Bernair
Cc: lilypond-user-fr@gnu.org
Sent: Friday, July 15, 2011 8:33 PM
Subject: Re: Caractères accentués

Normalement c'est dans jEdit :Utilitaires > Options générales > Encodages > Encodage de caractères par défaut
Mais c'est possible que cela ne vienne pas de là. En tout cas, LilyPond n'est pas la cause, c'est uniquement l'encodage du fichier.

Bertrand