Centrage du pied de page

Bonsoir à vous!

Je cherche désespérément à centrer mon texte de pied de page, mais je ne trouve pas la syntaxe qui fonctionne.
Cette syntaxe fonctionnait parfaitement dans des anciennes versions (au moins la 2.12.1, car c'est avec celle là que j'avais réussi à centrer tout ça à l'époque)
La syntaxe a donc du changer, mais je ne vois pas où!
En pièce jointe, le fichier .ly pour que vous puissiez me corriger!

Merci beaucoup d'avance
Laurent

licence.ly (1.07 KB)

···


----------------------------------------------------------------------------------------------

Ceci est ma nouvelle boîte e-mail.
L'ancienne était: ****@****
Merci de ne plus envoyer d' e-mail à cette adresse LaPoste.

---------------------------------------------------------------------------------------------- |

  • |

Bonsoir

Je cherche désespérément à centrer mon texte de pied de page, mais je ne
trouve pas la syntaxe qui fonctionne.

chez moi ceci fonctionne

%%------------------------
\header {
tagline = \markup {
  \left-align
  \column
  \center-align
  {
\line { ©Laurent Richard - 2009 }
\line { Cette partition est publiée suivant les termes de la Licence Creative Commons BY-NC-SA. }
\with-url #"http://creativecommons.org/licenses/by-nc-sa/2.0/fr/"
\line { http://creativecommons.org/licenses/by-nc-sa/2.0/fr/\}
\line{ Vous pouvez la reproduire, la distribuer et la jouer librement.}
\line { En revanche, il vous est interdit d'utiliser cette création à des fins commerciales. }
\line { Gravure réalisée au moyen du logiciel libre
\with-url #"http://www.LilyPond.org"
\bold {GNU LilyPond}.
\concat { #(ly:export (string-append "version " (lilypond-version)))
} .
     }
   }
}

{c'}
%%-----------------------------

···

--
Martial

bonsoir

tout vite une idée:

ajouter \markup \fill-line { " " \column { … } " "} (consulter la doc pour
les détails)

···

--
View this message in context: http://n2.nabble.com/Centrage-du-pied-de-page-tp4805929p4806786.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Merci beaucoup cette solution fonctionne!
En fait, il fallait jongler avec les \left-align \column et \center-align
J'ai du mal avec ces variables!

Au plaisir de vous lire
Laurent

···

Le vendredi 26 mars 2010 à 23:00 +0100, Martial a écrit :

Bonsoir

> Je cherche désespérément à centrer mon texte de pied de page, mais je ne
> trouve pas la syntaxe qui fonctionne.

chez moi ceci fonctionne

%%------------------------
\header {
tagline = \markup {
	\left-align
	\column 	
	\center-align
	{
\line { ©Laurent Richard - 2009 }
\line { Cette partition est publiée suivant les termes de la Licence 
Creative Commons BY-NC-SA. }
\with-url #"[http://creativecommons.org/licenses/by-nc-sa/2.0/fr/](http://creativecommons.org/licenses/by-nc-sa/2.0/fr/)"
\line { [http://creativecommons.org/licenses/by-nc-sa/2.0/fr/](http://creativecommons.org/licenses/by-nc-sa/2.0/fr/)}
\line{  Vous pouvez la reproduire, la distribuer et la jouer librement.}
\line { En revanche, il vous est interdit d'utiliser cette création à 
des fins commerciales. }
\line { Gravure réalisée au moyen du logiciel libre
\with-url #"[http://www.LilyPond.org](http://www.LilyPond.org)"
\bold {GNU LilyPond}.
\concat { #(ly:export (string-append "version " (lilypond-version)))
} .
     }
   }
}
}

{c'}
%%-----------------------------


----------------------------------------------------------------------------------------------

Ceci est ma nouvelle boîte e-mail.
L'ancienne était: ****@****
Merci de ne plus envoyer d' e-mail à cette adresse LaPoste.

---------------------------------------------------------------------------------------------- |

  • |

Bonsoir à vous!

Je cherche désespérément à centrer mon texte de pied de page, mais je ne trouve pas la syntaxe qui fonctionne.
Cette syntaxe fonctionnait parfaitement dans des anciennes versions (au moins la 2.12.1, car c'est avec celle là que j'avais réussi à >centrer tout ça à l'époque)
La syntaxe a donc du changer, mais je ne vois pas où!
En pièce jointe, le fichier .ly pour que vous puissiez me corriger!

Merci beaucoup d'avance
Laurent

J'ai eu le même problème avec la version 2.13.16 - je suis retourné à la version 2.13.7 et tout est rentré dans l'ordre.

À vérifier tout de même

Amicalement,

Jean-François