Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

Bonjour et très heureuse année 2019 à toutes et tous.

Aujourd’hui, je me bats avec Lilypond et Frescobaldi qui me posent problème en compilation. Hier tout était normal.

Je reçois le log d’erreur (voir la pièce jointe). Si je supprime le \header cela passe sans problème. Si je prends l’option ignore, la compilation se déroule normalement.

J’ai désinstallé la mise à jour de Windows 10 installée automatiquement aujourd’hui mais cela ne change rien. J’ai réinstallé la dernière version de Lilypond 2.19.81 mais sans changement.

Auriez-vous une idée ?

Bien amicalement,

Daniel Bernair

image001.gif

Bonsoir Daniel,
pourriez-vous poster votre code. ly qui déclenche cette erreur ? (ou un fichier ly minimal suffisant à reproduire le bug, par exemple avec le header en question.)

Cordialement,
V. V.

···

On January 9, 2019 10:58:04 PM GMT+01:00, "Daniel Bernair (Belgacom.net)" <****@****> wrote:

Je reçois le log d’erreur (voir la pièce jointe). Si je
supprime le \header cela passe sans problème.

Voici Valentin. Si je place le \header entre %{ et %} cela compile sans erreur. Je vois également ce matin que Windows 10 update a réinstallé automatiquement la mise à jour.
Bien amicalement.
Daniel Bernair

-----Message d'origine-----

CREDO ZIPOLI POUR Tenors & Basses.ly (14.6 KB)

···

De : Valentin Villenave <****@****> De la part de V. Villenave
Envoyé : mercredi 9 janvier 2019 23:20
À : lilypond-user-fr@gnu.org; Daniel Bernair (Belgacom.net) <****@****>
Objet : Re: Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

On January 9, 2019 10:58:04 PM GMT+01:00, "Daniel Bernair (Belgacom.net)" <****@****> wrote:

Je reçois le log d'erreur (voir la pièce jointe). Si je supprime le
\header cela passe sans problème.

Bonsoir Daniel,
pourriez-vous poster votre code. ly qui déclenche cette erreur ? (ou un fichier ly minimal suffisant à reproduire le bug, par exemple avec le header en question.)

Cordialement,
V. V.

Bon ben aucun rapport avec Windows, j'ai la même erreur sous MacOs avec ton fichier.

···

Christophe Pochon

Si je copie-colle le leader dans un autre document tout se passe bien.

Si j'enlève la ligne skipBars = ##t dans le layout, tout se passe bien...

···

Christophe Pochon

Je ne comprends pas très bien ce qui se passe car dans les fichiers encodés une semaine avant je n’ai pas de problème de compil. Ce n’est qu’avec celui-ci.

Je viens de neutraliser le skipBars = ##t en le mettant en commentaire selon la remarque de Christophe et cela compile sans problème. Également si je change skipbBars = ##f cela compile sans problème.

Bien amicalement.

Daniel Bernair

···

De : lilypond-user-fr <lilypond-user-fr-bounces+daniel.bernair=****@****> De la part de Christophe Pochon
Envoyé : jeudi 10 janvier 2019 10:33
À : Daniel Bernair (Belgacom.net) <****@****>
Cc : LilyPond lilypond-user-fr@gnu.org
Objet : Re: Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

Bon ben aucun rapport avec Windows, j'ai la même erreur sous MacOs avec ton fichier.

Christophe Pochon

Le jeu. 10 janv. 2019 à 09:37, Daniel Bernair (Belgacom.net) <****@****> a écrit :

Voici Valentin. Si je place le \header entre %{ et %} cela compile sans erreur. Je vois également ce matin que Windows 10 update a réinstallé automatiquement la mise à jour.
Bien amicalement.
Daniel Bernair

-----Message d'origine-----
De : Valentin Villenave <****@****> De la part de V. Villenave
Envoyé : mercredi 9 janvier 2019 23:20
À : lilypond-user-fr@gnu.org; Daniel Bernair (Belgacom.net) <****@****>
Objet : Re: Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

On January 9, 2019 10:58:04 PM GMT+01:00, "Daniel Bernair (Belgacom.net)" <****@****> wrote:

Je reçois le log d'erreur (voir la pièce jointe). Si je supprime le
\header cela passe sans problème.

Bonsoir Daniel,
pourriez-vous poster votre code. ly qui déclenche cette erreur ? (ou un fichier ly minimal suffisant à reproduire le bug, par exemple avec le header en question.)

Cordialement,
V. V.


liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user-fr

Remarque supplémentaire : en neutralisant skiBars = ##t je n’ai plus les mesures de silences condensés. En gardant skipBars = ##t mais en ignoran,t l’erreur de compil cela fonctionne parfaitement.

Daniel Bernair

···

De : Daniel Bernair (Belgacom.net) <****@****>
Envoyé : jeudi 10 janvier 2019 11:34
À : 'Christophe Pochon' <****@****>
Cc : 'LilyPond' lilypond-user-fr@gnu.org
Objet : RE: Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

Je ne comprends pas très bien ce qui se passe car dans les fichiers encodés une semaine avant je n’ai pas de problème de compil. Ce n’est qu’avec celui-ci.

Je viens de neutraliser le skipBars = ##t en le mettant en commentaire selon la remarque de Christophe et cela compile sans problème. Également si je change skipbBars = ##f cela compile sans problème.

Bien amicalement.

Daniel Bernair

De : lilypond-user-fr <lilypond-user-fr-bounces+daniel.bernair=****@****> De la part de Christophe Pochon
Envoyé : jeudi 10 janvier 2019 10:33
À : Daniel Bernair (Belgacom.net) <****@****>
Cc : LilyPond <lilypond-user-fr@gnu.org>
Objet : Re: Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

Bon ben aucun rapport avec Windows, j'ai la même erreur sous MacOs avec ton fichier.

Christophe Pochon

Le jeu. 10 janv. 2019 à 09:37, Daniel Bernair (Belgacom.net) <****@****> a écrit :

Voici Valentin. Si je place le \header entre %{ et %} cela compile sans erreur. Je vois également ce matin que Windows 10 update a réinstallé automatiquement la mise à jour.
Bien amicalement.
Daniel Bernair

-----Message d'origine-----
De : Valentin Villenave <****@****> De la part de V. Villenave
Envoyé : mercredi 9 janvier 2019 23:20
À : lilypond-user-fr@gnu.org; Daniel Bernair (Belgacom.net) <****@****>
Objet : Re: Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

On January 9, 2019 10:58:04 PM GMT+01:00, "Daniel Bernair (Belgacom.net)" <****@****> wrote:

Je reçois le log d'erreur (voir la pièce jointe). Si je supprime le
\header cela passe sans problème.

Bonsoir Daniel,
pourriez-vous poster votre code. ly qui déclenche cette erreur ? (ou un fichier ly minimal suffisant à reproduire le bug, par exemple avec le header en question.)

Cordialement,
V. V.


liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user-fr

en déplaçant \skipBars hors du context “score” ça semble aller mieux :

\layout {

skipBars = ##t

\context {

\Score… etc.

JLouis

Voici l’exemple minimal avec lequel j’arrive à reproduire le crash. Il
est manifeste que c’est ce \pageBreak au début du code qui est en
cause; peut-être une nouvelle occurrence de ce bug:
https://sourceforge.net/p/testlilyissues/issues/4943

\header { title = "foo bar" }
{
  \pageBreak
  c'1 \break
  c' \break
  \repeat unfold 4 c'
}

Cordialement,
V. V.

···

On 1/10/19, Daniel Bernair (Belgacom.net) <****@****> wrote:

Je ne comprends pas très bien ce qui se passe car dans les fichiers encodés
une semaine avant je n’ai pas de problème de compil. Ce n’est qu’avec
celui-ci.

Merci Valentin. Il y a effectivement un problème avec \pageBreak mais pas celui qui vient après ma première page de titres car si je le neutralise, j'obtiens toujours la même erreur.
Par contre, en neutralisant ceux qui se trouvent dans chaque début de musique, le problème ne se pose pas.
Voir :
PartPOneVoiceOne = \relative f' {
  \clef "treble_8" \stopStaff \override Staff.StaffSymbol #'line-count = #5
  \startStaff \key f \major \time 2/2 \tempo Allegro 2 = 66 \mark \markup { \box P.1 } %%\pageBreak
Ces premières instructions sont générées par le XML créé par PDFtoMusic PRO ou SharpEye 2 (je ne sais plus) et importé dans lilypond.
Bien amicalement,
Daniel Bernair.

-----Message d'origine-----

···

De : lilypond-user-fr <lilypond-user-fr-bounces+daniel.bernair=****@****> De la part de Valentin Villenave
Envoyé : jeudi 10 janvier 2019 14:53
À : Daniel Bernair (Belgacom.net) <****@****>
Cc : LilyPond <lilypond-user-fr@gnu.org>
Objet : Re: Compilation en erreur sous Lilypond 2.19.82 et Windows 10 X86

On 1/10/19, Daniel Bernair (Belgacom.net) <****@****> wrote:

Je ne comprends pas très bien ce qui se passe car dans les fichiers
encodés une semaine avant je n’ai pas de problème de compil. Ce n’est
qu’avec celui-ci.

Voici l’exemple minimal avec lequel j’arrive à reproduire le crash. Il est manifeste que c’est ce \pageBreak au début du code qui est en cause; peut-être une nouvelle occurrence de ce bug:
https://sourceforge.net/p/testlilyissues/issues/4943

\header { title = "foo bar" }
{
  \pageBreak
  c'1 \break
  c' \break
  \repeat unfold 4 c'
}

Cordialement,
V. V.

_______________________________________________
liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user-fr