conversion : messages bizarres

Salut à tous,

Je viens de faire une conversion de plusieurs fichiers vers la version 2.11.59
(en fait ça me les met à la 2.11.57 mais doit pas y avoir eu de changement
entre les deux) et pour certains fichiers (et je n'arrive pas à comprendre ce
qui les différencie des autres) je n'ai pas de conversion mais ce message
d'erreur :

convert-ly (GNU LilyPond) 2.11.59
Traceback (most recent call last):
  File "/usr/local/lilypond/usr/bin/convert-ly", line 316, in ?
    main ()
  File "/usr/local/lilypond/usr/bin/convert-ly", line 310, in main
    do_one_file (f)
  File "/usr/local/lilypond/usr/bin/convert-ly", line 215, in do_one_file
    ly.stderr_write (_ ("Processing `%s\'... ") % infile_name)
  File "/usr/local/lilypond/usr/share/lilypond/current/python/lilylib.py",
line 67, in stderr_write
    encoded_write (sys.stderr, s)
  File "/usr/local/lilypond/usr/share/lilypond/current/python/lilylib.py",
line 59, in encoded_write
    f.write (s.encode (f.encoding or 'utf_8'))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 54:
ordinal not in range(128)

C'est un bug ?

···

--
Cordialement, Daniel Cartron
« Je pompe donc je suis. »
Devise Shadock

Je viens de faire une conversion de plusieurs fichiers vers la version 2.11.59
(en fait ça me les met à la 2.11.57 mais doit pas y avoir eu de changement
entre les deux) et pour certains fichiers (et je n'arrive pas à comprendre ce
qui les différencie des autres) je n'ai pas de conversion mais ce message
d'erreur :[..]

C'est un bug ?

Est ce que par hasard tu le fais avec LilypondTools ?
Chez moi ça me dit à chaque fois "fichier en lecture seule" quand je le fais depuis JEdit
et je suis obligé de le faire en ligne de commande.
Mais ça n'a peut-être rien à voir.

Gilles

Est ce que par hasard tu le fais avec LilypondTools ?

Non je le fais avec mon servicemenu (K-lily que finalement j'ai rebaptisé
Klyc, pour KDE Lilypond Companion) mais en ligne de commande c'est pareil.

Chez moi ça me dit à chaque fois "fichier en lecture seule" quand je le
fais depuis JEdit

moi j'ai pas ça juste les messages indiqués et qui sont les mm quelque soit le
fichier et le mode de lancement de la commande, script ou manuel...

et je suis obligé de le faire en ligne de commande.
Mais ça n'a peut-être rien à voir.

On dirait que non en effet mais merci.

PS Je finis de mettre la dernière touche à mon servicemenu et je vous en
reparle...

···

Le dimanche 30 novembre 2008, Gilles THIBAULT a écrit :

--
Cordialement, Daniel Cartron
« Je voudrais que la terre s'arrête pour descendre. »
Serge Gainsbourg

je n'ai pas de souci de conversion avec JEdit (winXP)

Mais la dernière version est la 2.11.65

peut-être un bug sous la 2.11.59, je ne me souvient pas !

···

--
Martial