convert-ly : mise à jour des scripts source

Bonjour à tous,

Ce matin je mets mon système à jour :
installation de la dernière version de lilypond
mise à jour des scripts en cours de réalisation

Le script python convert-ly ne s'exécute pas !

Après investigations, voici ma solution, sous Linux Kubuntu edgy

éditer le fichier texte
/usr/local/lilypond/usr/bin/convert-ly
rem. : l'emplacement peut varier selon l'OS et les options d'installation

modifier la première ligne qui doit être :
#!/usr/local/lilypond/usr/bin/python

et non un chemin commençant par #/home/lilydev (je n'ai pas conservé l'ancienne données, elle ressemblait fort à un environnement de développement)

pour pointer sur le python embarqué avec lilypond, et non le python système.

ajouter :

ajout bibliothèques locales

bindir = os.path.split (sys.argv[0])[0]
datadir = os.path.abspath (bindir + '/../share/lilypond/current/python/' )
sys.path.insert (0, datadir)

fin ajout

au dessus de la ligne :
import lilylib as ly

J'ai mis à jour mes fichiers .ly, sans erreur, j'en ai mouliné un, pas de soucis à par un problème d'encodage (lié ? à voir par la suite)

Faut-il remonter l'information à la liste anglophone et à celle de développement ?
J'ai cherché sur le site lilypond.org, je n'ai pas vu de bug associé.

Bonne journée

Pierre-Emmanuel

Bonjour à tous,

Ce matin je mets mon système à jour :
installation de la dernière version de lilypond
mise à jour des scripts en cours de réalisation

Le script python convert-ly ne s'exécute pas !

Après investigations, voici ma solution, sous Linux Kubuntu edgy

Utilises-tu les paquets GUB ou les paquets d'Ubuntu ? De quel version
de LilyPond s'agit-il ?

[...]

Faut-il remonter l'information à la liste anglophone et à celle de
développement ?

Si cela concerne le paquet GUB la dernière version stable (2.10) ou de
développement (2.11)

J'ai cherché sur le site lilypond.org, je n'ai pas vu de bug associé.

Les bogues sont répertoriés sur
http://code.google.com/p/lilypond/issues/list

La marche a suivre pour rapporter un bogue est décrite à
http://lilypond.org/web/devel/participating/bugs

Cependant, la liste bug-lilypond n'accepte que les rapports en anglais,
donc les rapports en français doivent être envoyés sur cette liste
(lilypond-user-fr !) pour traduction.

Pour revenir à ton problème précis, il me semble que tu devrais d'abord
en faire part au mainteneur du paquet Ubuntu si tu l'utilises.

Bonne après-midi

···

Le lundi 19 mars 2007 à 13:09 +0100, P.E. Brame a écrit :
--
John Mandereau <****@****>

re-Bonjour

John Mandereau a écrit :

Le lundi 19 mars 2007 à 13:09 +0100, P.E. Brame a écrit :
  
Bonjour à tous,

Ce matin je mets mon systÚme à jour :
installation de la derniÚre version de lilypond
mise à jour des scripts en cours de réalisation

Le script python convert-ly ne s'exécute pas !

AprÚs investigations, voici ma solution, sous Linux Kubuntu edgy 
    

Utilises-tu les paquets GUB ou les paquets d'Ubuntu ?  De quel version
de LilyPond s'agit-il ?

J'ai utilisé le script d'installation lilypond-2.10.14-1.linux-x86.sh
  

C'est quoi un paquet GUB ? ce nom faisait partie du chemin de la première ligne

[...]
  
Faut-il remonter l'information à la liste anglophone et à celle de
développement ?
    

Si cela concerne le paquet GUB la derniÚre version stable (2.10) ou de
développement (2.11)

  
J'ai cherché sur le site lilypond.org, je n'ai pas vu de bug associé.
    

Les bogues sont répertoriés sur
[http://code.google.com/p/lilypond/issues/list](http://code.google.com/p/lilypond/issues/list)

La marche a suivre pour rapporter un bogue est décrite à 
[http://lilypond.org/web/devel/participating/bugs](http://lilypond.org/web/devel/participating/bugs)

Cependant, la liste bug-lilypond n'accepte que les rapports en anglais,
donc les rapports en français doivent être envoyés sur cette liste
(lilypond-user-fr !) pour traduction.
  

Je maîtrise assez l'anglais pour rédiger le rapport, si l'envoi sur la liste n'est que pour traduction

Pour revenir à ton problÚme précis, il me semble que tu devrais d'abord
en faire part au mainteneur du paquet Ubuntu si tu l'utilises.
  

Ubuntu travaille en coopération avec Debian, la mise à jour des paquets "annexes" pour eux est très lente ! Les paquets proposent la version 2.6.3