Décalage de l'espace dans la mesure de levée | cause : \tempo

Bonjour à tous,

Je suis depuis 2 heures face à un problème que j'ai enfin réussi à localiser sans pour autant le résoudre !
Dans la mesure en levée (\partial 4) il y a une noire qui se trouve très espacée de la barre de mesure qui suit (espace équivalent à 2 croches) seulement lorsque je mets \tempo 4=60. Si je l'enlève l'espacement redevient "normal".
De plus, si je force le déplacement vers la gauche et vers le haut de l'indication de tempo (avec \override Score.MetronomeMark #'extra-offset = #'( -10.0 . 2.0 )), cela n'a aucune incidence.

Est-ce un bug ?

Enfin, pour enrober encore plus ce problème de mystère, dans la partition finale (qui est un peu plus longue !!!!) et bien l'espacement est correct entre la noire et la barre de mesure AVEC L'INDICATION DE TEMPO si et seulement si je n'utilise pas la fonction de transposition (dans le bloc score). Et l'espacement devient trop large si j'utilise la fonction \transpose f c. (évidemment si je n'utilise pas la fonction \tempo, tout est en ordre dans la partition finale dans tous les cas).

Si quelqu'un a une idée.

Ah si j'ai trouvé une solution en "bricolant" :
mettre la fonction \tempo, une mesure plus loin, c'est-à-dire après la 1ère mesure, en forçant un (énorme) décalage vers la gauche !!!!!!

Merci à vous.
Cordialement,

essai.ly (1.73 KB)

···

--
Luc De Rossi
Lilypond 2.11.34
Ubuntu Lucid Lynx

Pas de souci ici (dernière version de développement).
Tu utilises quelle version ? Il peut s'agir d'un bug propre à cette
version qui a été corrigé depuis.

Cordialement,
Xavier

···

2011/6/4 Luc De Rossi <****@****>:

Bonjour à tous,

Je suis depuis 2 heures face à un problème que j'ai enfin réussi à localiser
sans pour autant le résoudre !
Dans la mesure en levée (\partial 4) il y a une noire qui se trouve très
espacée de la barre de mesure qui suit (espace équivalent à 2 croches)
seulement lorsque je mets \tempo 4=60. Si je l'enlève l'espacement redevient
"normal".
De plus, si je force le déplacement vers la gauche et vers le haut de
l'indication de tempo (avec \override Score.MetronomeMark #'extra-offset =
#'( -10.0 . 2.0 )), cela n'a aucune incidence.

Est-ce un bug ?

Enfin, pour enrober encore plus ce problème de mystère, dans la partition
finale (qui est un peu plus longue !!!!) et bien l'espacement est correct
entre la noire et la barre de mesure AVEC L'INDICATION DE TEMPO si et
seulement si je n'utilise pas la fonction de transposition (dans le bloc
score). Et l'espacement devient trop large si j'utilise la fonction
\transpose f c. (évidemment si je n'utilise pas la fonction \tempo, tout est
en ordre dans la partition finale dans tous les cas).

Si quelqu'un a une idée.

Ah si j'ai trouvé une solution en "bricolant" :
mettre la fonction \tempo, une mesure plus loin, c'est-à-dire après la 1ère
mesure, en forçant un (énorme) décalage vers la gauche !!!!!!

--
Xavier Scheuer <****@****>

Xavier,

Je te remercie pour cette information. Effectivement, je traîne une vieille version (2.11.34) terminant un travail de 230 petites partitions toutes bâties sur le même modèle... et le courage me manquait de convertir les 230 fichiers !
Mais décidément, il urge que je migre vers la version 2.14, fraîchement arrivée !

Cordialement,
Luc

···

Le 04/06/2011 17:29, Xavier Scheuer a écrit :

2011/6/4 Luc De Rossi<****@****>:

Bonjour à tous,

Je suis depuis 2 heures face à un problème que j'ai enfin réussi à localiser
sans pour autant le résoudre !
Dans la mesure en levée (\partial 4) il y a une noire qui se trouve très
espacée de la barre de mesure qui suit (espace équivalent à 2 croches)
seulement lorsque je mets \tempo 4=60. Si je l'enlève l'espacement redevient
"normal".
De plus, si je force le déplacement vers la gauche et vers le haut de
l'indication de tempo (avec \override Score.MetronomeMark #'extra-offset =
#'( -10.0 . 2.0 )), cela n'a aucune incidence.

Est-ce un bug ?

Enfin, pour enrober encore plus ce problème de mystère, dans la partition
finale (qui est un peu plus longue !!!!) et bien l'espacement est correct
entre la noire et la barre de mesure AVEC L'INDICATION DE TEMPO si et
seulement si je n'utilise pas la fonction de transposition (dans le bloc
score). Et l'espacement devient trop large si j'utilise la fonction
\transpose f c. (évidemment si je n'utilise pas la fonction \tempo, tout est
en ordre dans la partition finale dans tous les cas).

Si quelqu'un a une idée.

Ah si j'ai trouvé une solution en "bricolant" :
mettre la fonction \tempo, une mesure plus loin, c'est-à-dire après la 1ère
mesure, en forçant un (énorme) décalage vers la gauche !!!!!!

Pas de souci ici (dernière version de développement).
Tu utilises quelle version ? Il peut s'agir d'un bug propre à cette
version qui a été corrigé depuis.

Cordialement,
Xavier

--
Luc De Rossi
Lilypond 2.11.34
Ubuntu Lucid Lynx