Difficulté

Bonjour à tous,
Employant lilypond-2.10 pour la musique avec noteedit-2.8.1, si la partition commence par une mesure multi-silence ex:___5___ lilypond déclare error lorsqu'il transforme le fichier.ly en ps et pdf. De plus mais cela n'est pas important à mes yeux, il ne fournit plus de fichier.dvi. Peut-être que je n'ai pas toutes les dépendances.
Merci pour votre compréhension.
Michel

Bonjour,

Est-ce qu'il serait possible de nous donner un extrait de fichier ly
qui pose problème, et le système d'exploitation utilisé?

Lilypond ne donne plus automatiquement de fichier ly, il faut le lui
demander avec un argument:

lilypond --dvi fichier.ly

Ludovic

···

2006/12/4, michel pondeville <****@****>:

Bonjour à tous,
Employant lilypond-2.10 pour la musique avec noteedit-2.8.1, si la partition
commence par une mesure multi-silence ex:___5___ lilypond déclare error
lorsqu'il transforme le fichier.ly en ps et pdf. De plus mais cela n'est
pas important à mes yeux, il ne fournit plus de fichier.dvi. Peut-être que
je n'ai pas toutes les dépendances.
Merci pour votre compréhension.
Michel

Bonjour,

Ludovic Sardain a écrit :
> Lilypond ne donne plus automatiquement de fichier dvi, il faut le lui
> demander avec un argument:
>
> lilypond --dvi fichier.ly

   Sauf que la documentation dit "tex backend only" et la commande "lilypond --dvi fichier.ly" renvoie "impossible de générer DVI à l'aide du support postscript".
   Comme c'est mon premier test avec LilyPond je ne pourrai pas en dire plus, et en plus j'ai un soucis avec les polices. Soit l'ECM suivant

\version "2.10.0"
\header {
   title = "Évènement"
}
\new Score {
a
}

La sortie PDF ne comporte pas d'accent, le titre est "ment" et la compilation me renvoie

erreur de programmation : FT_Get_Glyph_Name returns error
erreur de programmation : Le glyphe n'a pas de nom, mais la fonte prend en charge le nommage de glyphes.
Glyphe U+FFFFFFFF ignoré dans le fichier /usr/share/lilypond/usr/share/lilypond/current/fonts/otf//CenturySchL-Bold.otf

   J'utilise la version 2.10.0 sous Linux (FC5 x86_64). Un autre problème, si je fais

lilypond -b texstr test.ly

avec le fichier test.ly

\version "2.10.0"
\new Score {
a
}

la compilation renvoie

/usr/share/lilypond/usr/bin/../share/lilypond/current/ly/init.ly:41:1: ERREUR : GUILE a signalé une erreur pour l'expression débutant ici

···

#
  (if (pair? toplevel-scores)
Wrong type argument in position 1...

   C'est un bug ce truc ?

Cordialement,

--Jyb

Bonjour,

Ludovic Sardain a écrit :
> Lilypond ne donne plus automatiquement de fichier dvi, il faut le lui
> demander avec un argument:
>
> lilypond --dvi fichier.ly

   Sauf que la documentation dit "tex backend only" et la commande
"lilypond --dvi fichier.ly" renvoie "impossible de générer DVI à l'aide
du support postscript".

désolé, je n'en sais pas plus

   Comme c'est mon premier test avec LilyPond je ne pourrai pas en dire
plus, et en plus j'ai un soucis avec les polices. Soit l'ECM suivant

\version "2.10.0"
\header {
   title = "Évènement"
}
\new Score {
a
}

La sortie PDF ne comporte pas d'accent, le titre est "ment" et la
compilation me renvoie

erreur de programmation : FT_Get_Glyph_Name returns error
erreur de programmation : Le glyphe n'a pas de nom, mais la fonte prend
en charge le nommage de glyphes.
Glyphe U+FFFFFFFF ignoré dans le fichier
/usr/share/lilypond/usr/share/lilypond/current/fonts/otf//CenturySchL-Bold.otf

J'ai eu un problème similaire il y a longtemps, et j'ai longtemps
cherché avant de me rendre compte que mon fichier n'avait pas le même
codage que mon système.

   J'utilise la version 2.10.0 sous Linux (FC5 x86_64). Un autre
problème, si je fais

lilypond -b texstr test.ly

avec le fichier test.ly

\version "2.10.0"
\new Score {
a
}

la compilation renvoie

/usr/share/lilypond/usr/bin/../share/lilypond/current/ly/init.ly:41:1:
ERREUR : GUILE a signalé une erreur pour l'expression débutant ici
#
  (if (pair? toplevel-scores)
Wrong type argument in position 1...

   C'est un bug ce truc ?

Cordialement,

--Jyb

Ludovic

···

Le 06/12/06, Jean-Yves Baudais<****@****> a écrit :

_______________________________________________
liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-user-fr

Bonjour,

Ludovic Sardain a écrit :

J'ai eu un problème similaire il y a longtemps, et j'ai longtemps
cherché avant de me rendre compte que mon fichier n'avait pas le même
codage que mon système.

   J'ai changé le codage de ISO-8859-1 vers UTF-8 et tout fonctionne. Merci. Par contre ça ne change rien pour l'utilisation de l'option texstr, il y a toujours la même erreur :

/usr/share/lilypond/usr/bin/../share/lilypond/current/ly/init.ly:41:1: ERREUR :
GUILE a signalé une erreur pour l'expression débutant ici

···

#
  (if (pair? toplevel-scores)
Wrong type argument in position 1...

   Comment résoudre ça ?

--Jyb