Emacs mode

Bonjour,

J'essaye en vain d'installer le Lilypond-mode pour Emacs sur ma Ubuntu. J'ai ajouté la ligne suivante dans mon fichier .emacs
(setq load-path (append (list (expand-file-name "/usr/local/lilypond/usr/share/emacs/site-lisp/")) load-path))
J'ai copié les fichiers "lilypond-init.el", "lilipond-indent.el" ... dans tous les dossiers /emacs/site-lisp/ que je trouvais mais rien ne fonctionne.

Si quelqu'un à une idée. Merci.

Christophe

Bonjour,

Bonjour

J'essaye en vain d'installer le Lilypond-mode pour Emacs sur ma Ubuntu.
J'ai ajouté la ligne suivante dans mon fichier .emacs
(setq load-path (append (list (expand-file-name
"/usr/local/lilypond/usr/share/emacs/site-lisp/")) load-path))
J'ai copié les fichiers "lilypond-init.el", "lilipond-indent.el" ...
dans tous les dossiers /emacs/site-lisp/ que je trouvais mais rien ne
fonctionne.

J'ai mis les fichiers dans /usr/local/share/emacs/site-lisp
modifié le load-path comme tu l'indiques et
j'ai ça dans mon emacs.el
(load "lilypond-init.el" t t)
et ça marche (sans modif de lilypond-init.el, je viens de vérifier).

Si quelqu'un à une idée. Merci.

jeqça

···

Le Jeudi 18 Janvier 2007 11:51, Christophe Richard a écrit :

--
Yvon Henel

Je n'ai que ça au sujet de Llypond, dans mon .emacs :

;; Lilypond mode
(load "lilypond-init.el" t t)

···

Le Thu, 18 Jan 2007 11:51:39 +0100 Christophe Richard <****@****> a écrit :

Si quelqu'un à une idée.

--
Denis

Denis Bitouzé a écrit :

Si quelqu'un à une idée.

Je n'ai que ça au sujet de Llypond, dans mon .emacs :

;; Lilypond mode
(load "lilypond-init.el" t t)

Chez moi, ça ne marche pas si je ne précise pas load-path
(setq load-path (cons (expand-file-name "~/.elisp") load-path))
C'est évidemment à adapter.
debjjr@zoe:~$ ls ~/.elisp
gnus lilypond-init.el pi-tempo-abbrev-asy.el
lily-emacs.el lilypond-mode.el pi-tempo-abbrev.el
lily-emacs.el.tar.gz lilypond-what-beat.el pi-tempo-abbrev-latex.el
lilypond-font-lock.el lilypond-words.el pi-tempo-abbrev-lisp.el
lilypond-indent.el lyqi

J'ai en plus le mode lyqi (génial !)

(setq load-path (cons (expand-file-name "~/.elisp/lyqi") load-path))

;; when loading LilyPond-mode, lyqi-mode library will also be loaded.
;; type `C-c q' in LilyPond-mode to switch to lyqi-mode.

(eval-after-load "lilypond-mode"
   '(progn
      (load-library "lyqi-mode")
      (define-key LilyPond-mode-map "\C-cq" 'lyqi-mode)))

avec
debjjr@zoe:~$ ls ~/.elisp/lyqi/
lyqi-base.el lyqi-editor.elc lyqi-mode.el lyqi-parser.elc
lyqi-base.elc lyqi-midi.el lyqi-mode.elc lyqi-rumor.el
lyqi-editor.el lyqi-midi.elc lyqi-parser.el lyqi-rumor.elc

···

Le Thu, 18 Jan 2007 11:51:39 +0100 > Christophe Richard <****@****> a écrit :

--
Jean-Jacques Rétorré

% Les gens qui ne rient jamais ne sont pas des gens sérieux (A. Allais).
--

Merci à tous pour vos réponses.

J'ai finalement réussi à l'installer en :

- copiant le fichier "lilypond-init.el" situé dans le dossier "usr/local/lilypond/usr/local/lilypond/usr/share/emacs/site-lisp/" vers le dossier "/etc/emacs/site-start.d" et en le renommant dans mon cas en "50lilypond-init.el"

- et en ajoutant la ligne suivante à mon .emacs

@@(setq load-path (append (list (expand-file-name "/usr/local/lilypond/usr/share/emacs/site-lisp/")) load-path))@@

Ce ne doit pas être la méthode la plus simple mais cela fonctionne et je n'y touche plus :wink:

Christophe.

Jean-Jacques Rétorré a écrit :

···

Denis Bitouzé a écrit :

Le Thu, 18 Jan 2007 11:51:39 +0100 >> Christophe Richard <****@****> a écrit :

Si quelqu'un à une idée.

Je n'ai que ça au sujet de Llypond, dans mon .emacs :

;; Lilypond mode
(load "lilypond-init.el" t t)

Chez moi, ça ne marche pas si je ne précise pas load-path
(setq load-path (cons (expand-file-name "~/.elisp") load-path))
C'est évidemment à adapter.
debjjr@zoe:~$ ls ~/.elisp
gnus lilypond-init.el pi-tempo-abbrev-asy.el
lily-emacs.el lilypond-mode.el pi-tempo-abbrev.el
lily-emacs.el.tar.gz lilypond-what-beat.el pi-tempo-abbrev-latex.el
lilypond-font-lock.el lilypond-words.el pi-tempo-abbrev-lisp.el
lilypond-indent.el lyqi

J'ai en plus le mode lyqi (génial !)

(setq load-path (cons (expand-file-name "~/.elisp/lyqi") load-path))

;; when loading LilyPond-mode, lyqi-mode library will also be loaded.
;; type `C-c q' in LilyPond-mode to switch to lyqi-mode.

(eval-after-load "lilypond-mode"
  '(progn
     (load-library "lyqi-mode")
     (define-key LilyPond-mode-map "\C-cq" 'lyqi-mode)))

avec
debjjr@zoe:~$ ls ~/.elisp/lyqi/
lyqi-base.el lyqi-editor.elc lyqi-mode.el lyqi-parser.elc
lyqi-base.elc lyqi-midi.el lyqi-mode.elc lyqi-rumor.el
lyqi-editor.el lyqi-midi.elc lyqi-parser.el lyqi-rumor.elc

Le 18.01.2007 11:51, Christophe Richard disait :

Bonjour,

J'essaye en vain d'installer le Lilypond-mode pour Emacs sur ma Ubuntu. J'ai ajouté la ligne suivante dans mon fichier .emacs
(setq load-path (append (list (expand-file-name "/usr/local/lilypond/usr/share/emacs/site-lisp/")) load-path))
J'ai copié les fichiers "lilypond-init.el", "lilipond-indent.el" ... dans tous les dossiers /emacs/site-lisp/ que je trouvais mais rien ne fonctionne.

Si quelqu'un à une idée. Merci.

Christophe

Sous Linux, après avoir installé LilyPond une première fois, il m'a suffit d'ajouter à mon ~/.emacs

;; pour LilyPond
(load "~/lilypond/usr/share/emacs/site-lisp/lilypond-init")

pour que tout marche comme sur des roulettes.
Ainsi, losrque je fais une mise à jour, je n'ai rien à modifier.

Bonne continuation,

Jean-Charles