encore et toujours le MIDI dans JEdit

Bonjour,

Toujours ce même problème de MIDI qui ne veut pas se faire entendre.

Voici ma partie \score d'un e partition quelconque :

\score {
  
  <<
   \new StaffGroup <<

   \new Staff \with {
     \override SpacingSpanner #'uniform-stretching = ##t }
     {\cello }
   \new Staff \with {
     \override SpacingSpanner #'uniform-stretching = ##t }
     {\basson }

  >>

  \layout {
    
     \context {
       \Score
       \override SpacingSpanner
         #'base-shortest-duration = #(ly:make-moment 1 2) }
  }
  \midi { }
}

Avec ces indications, lilypond me sort une superbe partition avec deux
voix mais lorsque je veux écouter avec le lecteur midi de lilypond,
celui ci avance mais ne me sort rien ! Pourtant ma carte son fonctionne
(cdrom, dvd, radio, youtube)

J'ai déjà posé la question sur la liste mais je n'ai pas eu de résultat
probant. Peut être que cette fois-ci ?...

Lilypond \version "2.15.25"
JEdit 4.4pre1, mode serveur, utilisant la version Sun Microsystems Inc.
de Java
LinuxMint Katya

Merci de votre aide

···

--
JJG

Bonjour,
Il me semble que le bloc \midi se met
http://lilypond.org/doc/v2.14/Documentation/notation/midi-block.fr.html dans
bloc score , non ?

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/encore-et-toujours-le-MIDI-dans-JEdit-tp7239574p7244150.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Jean-Jacques Gerbaud wrote

Bonjour,

Toujours ce même problème de MIDI qui ne veut pas se faire entendre.

Voici ma partie \score d'un e partition quelconque :

Avec ces indications, lilypond me sort une superbe partition avec deux
voix mais lorsque je veux écouter avec le lecteur midi de lilypond,
celui ci avance mais ne me sort rien ! Pourtant ma carte son fonctionne
(cdrom, dvd, radio, youtube)

J'ai déjà posé la question sur la liste mais je n'ai pas eu de résultat
probant. Peut être que cette fois-ci ?...

Lilypond \version "2.15.25"
JEdit 4.4pre1, mode serveur, utilisant la version Sun Microsystems Inc.
de Java
LinuxMint Katya

la question: est-ce que le fichier ….mid (ou midi) a-t-il été créé? -->
vérifier avec un explorateur dans le même dossier où se trouvent les
fichiers .ly et .pdf!

si oui --> essayer de l'ouvrir. quel est le résultat?

cordialement
Eluze

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/encore-et-toujours-le-MIDI-dans-JEdit-tp7239574p7244325.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

legoss a écrit :

Bonjour,
Il me semble que le bloc \midi se met GNU LilyPond – Manuel de notation: 3.5.2 Le bloc MIDI dans
bloc score , non ?

Merci de la réponse mais somme tu peux le voir, le bloc \midi *est* dans le bloc \score

Et pour Eluze, oui, dans le répertoire de fichier Lilypond, il y a bien :
- un fichier.ly,
- un fichier .midi
-un fichier .pdf !

Et si j'essaie d'ouvrir le fichier .midi, je peux entendre ce que je viens de "pondre" avec lilypond, avec n'importe quel lecteur lisant le midi, soit timidity, banshee ou gnome video, ou... ? (sauf VLC qui ne lit pas les fichiers midi)

Ce qui est surprenant, c'est qu'auparavant, le lecteur midi de JEdit foncmtionnait très bien mais j'ai laissé passer un peu de temps sans l'utiliser et, entretemps, j'ai dû faire quelque chose qui ne lui plaît pas. Quant à trouver ce que j'ai fait pour lui être désagréable ... ?

Si vous aviez d'autres pistes...

Merci d'avance

···

--
JJG

LibreOffice 3.3.4 (Ubuntu package 1:3.3.4-0ubuntu1)
LinuxMint Katya

elviejo wrote

Et pour Eluze, oui, dans le répertoire de fichier Lilypond, il y a bien :
- un fichier.ly,
- un fichier .midi
-un fichier .pdf !

Et si j'essaie d'ouvrir le fichier .midi, je peux entendre ce que je
viens de "pondre" avec lilypond, avec n'importe quel lecteur lisant le
midi, soit timidity, banshee ou gnome video, ou... ? (sauf VLC qui ne
lit pas les fichiers midi)

Ce qui est surprenant, c'est qu'auparavant, le lecteur midi de JEdit
foncmtionnait très bien mais j'ai laissé passer un peu de temps sans
l'utiliser et, entretemps, j'ai dû faire quelque chose qui ne lui plaît
pas. Quant à trouver ce que j'ai fait pour lui être désagréable ... ?

je n'utilise jamais jEdit

mon idée serait d'inspecter les options et sinon de désinstaller et
réinstaller jEdit…

Eluze

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/encore-et-toujours-le-MIDI-dans-JEdit-tp7239574p7246877.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Ce qui est surprenant, c'est qu'auparavant, le lecteur midi de JEdit foncmtionnait très bien mais j'ai laissé passer un peu de temps sans l'utiliser et, entretemps, j'ai dû faire quelque chose qui ne lui plaît pas. Quant à trouver ce que j'ai fait pour lui être désagréable ... ?

Si vous aviez d'autres pistes...

Ça ne fonctionnait pas chez moi non plus (Debian/wheezy) version des dépôts.

J'ai installé la version «java-based installer»
http://jedit.org/index.php?page=download
J'ai viré le lilypond-tool puis réinstallé.
Maintenant, ça marche.
Peut-être suffit-il de faire la même manip sur une installation défectueuse. Ce qui est sûr, c'est qu'il y a un bug dans jedit, il ne sert à rien de s'énerver sur le source lilypond.

Espérant que ça aide.

···

--
JJR.

Jean-Jacques Rétorré a écrit :

Ce qui est surprenant, c'est qu'auparavant, le lecteur midi de JEdit foncmtionnait très bien mais j'ai laissé passer un peu de temps sans l'utiliser et, entretemps, j'ai dû faire quelque chose qui ne lui plaît pas. Quant à trouver ce que j'ai fait pour lui être désagréable ... ?

Si vous aviez d'autres pistes...

Ça ne fonctionnait pas chez moi non plus (Debian/wheezy) version des dépôts.

J'ai installé la version «java-based installer»
http://jedit.org/index.php?page=download
J'ai viré le lilypond-tool puis réinstallé.
Maintenant, ça marche.
Peut-être suffit-il de faire la même manip sur une installation défectueuse. Ce qui est sûr, c'est qu'il y a un bug dans jedit, il ne sert à rien de s'énerver sur le source lilypond.

Espérant que ça aide.

Bonsoir Jean-Jacques,

Et bien non ! :frowning:

J'ai viré mon fichier /home/usr/.jedit, téléchargé le «java-based installer», installé à nouveau jedit avec la commande "/usr/bin/java -jar jedit4.5.0install.jar" (usr/bin/java étant l'endroit de mon installation de java) mais rien n'y a fait : mon lecteur midi reste désespérément muet.

ma version de lilypond, maintenant "2.15.27" (soit, dernière version de java, dernière version de ilypond, dernière version de jEdit !)

Je rappelle que je peux lire mes fichiers générés avec lilypond avec le lecteur Banshee ou Timidity.

Je signale également que sur une autre version de Ubuntu, installé parallèlement à ma Linuxint actuelle, le lecteur midi de jEdit fonctionne parfaitement.

A l'aiiide !

···

--
JJG

LibreOffice 3.3.4 (Ubuntu package 1:3.3.4-0ubuntu1)
LinuxMint Katya