erreur compilation documentation

Bonsoir,

Je n'arrive pas à compiler la documentation de lilypond.

La lecture de la page suivante :
http://lilypond.org/doc/v2.13/Documentation/topdocs/INSTALL m'a amené
à effectuer les actions suivantes :
dans un nouveau répertoire vide :

git clone git://git.sv.gnu.org/lilypond.git

En administrateur :
apt-get build-dep lilypond

Jusque là tout s'exécute sans erreur.

C'est là que ça se complique : en exécutant :

./autogen.sh

j'obtiens le message suivant m'invitant à installer texi2html :

WARNING: Please consider installing optional programs: texi2html

J'installe donc texi2html (1.82-1 comme recommandé dans la doc
lilypond en forçant la version car debian 5 propose la 1.78 par
défaut)
Pour installer texi2html mon gestionnaire de paquets me désinstalle de
force : texinfo et installe install-info. Jusque là bon, je lui fait
confiance.

Mais dans cette situation la commande

./autogen.sh

retourne un message d'erreur me semblant un peu plus sérieux :

ERROR: Please install required programs: makeinfo

Dans les deux cas, la commande

make doc

échoue au bout de quelques secondes

make: *** Pas de règle pour fabriquer la cible « doc ». Arrêt.

et dans le cas où texi2html n'est pas installé :

make[3]: Leaving directory `/home/user/lilypond-web/lilypond/input/regression'
make[2]: *** [WWW-1] Error 2
make[2]: Leaving directory `/home/user/lilypond-web/lilypond/input'
make[1]: *** [WWW-1] Error 2
make[1]: Leaving directory `/home/user/lilypond-web/lilypond'
make: *** [doc-stage-1] Erreur 2

Comment s'en sortir un tant soit peu proprement ? Désolé si la
question a déjà été posée, mes recherches sont restées infructueuses
....

Je suis sur debian lenny (5) avec processeur 32bits.

J'installe donc texi2html (1.82-1 comme recommandé dans la doc
lilypond en forçant la version car debian 5 propose la 1.78 par
défaut)
Pour installer texi2html mon gestionnaire de paquets me désinstalle de
force : texinfo et installe install-info. Jusque là bon, je lui fait
confiance.

C'est une erreur de la part des empaqueteurs de Debian : même en
remplaçant makeinfo par texi2html (ce qui est effectivement possible,
mais les empaqueteurs n'ont pas pris le soin de faire en sorte qu'un
lien symbolique de makeinfo vers texi2thml soit créé, d'où l'erreur
ci-dessous), texinfo contient texi2pdf, script pour lequel Texi2HTML ne
propose aucun remplacement. Bref, en attendant quelques semaines la
sortie de Texinfo 5, il faut installer à la fois Texinfo et Texi2HTML.

Comment s'en sortir un tant soit peu proprement ? Désolé si la
question a déjà été posée, mes recherches sont restées infructueuses
....

Non, cette question n'a jamais été posée, c'est la première fois qu'on
nous rapporte une erreur de gestion de paquets aussi grossière. Merci
de rapporter cette erreur aux mainteneurs des paquets concernés pour
Debian.

Salutations lilyesques,
John

···

Le samedi 21 novembre 2009 à 20:12 +0100, Michel Villeneuve a écrit :

Astuce : il est beaucoup plus simple d'installer texi2html
manuellement que de forcer l'installation de je ne sais quelle version
(en tout cas, j'ai personnellement renoncé à utiliser le texi2html de
ma distribution, que ce soit Arch, buntu ou Mandriva).

Cordialement,
Valentin

···

2009/11/21 John Mandereau <****@****>:

C'est une erreur de la part des empaqueteurs de Debian : même en
remplaçant makeinfo par texi2html (ce qui est effectivement possible,
mais les empaqueteurs n'ont pas pris le soin de faire en sorte qu'un
lien symbolique de makeinfo vers texi2thml soit créé, d'où l'erreur
ci-dessous), texinfo contient texi2pdf, script pour lequel Texi2HTML ne
propose aucun remplacement. Bref, en attendant quelques semaines la
sortie de Texinfo 5, il faut installer à la fois Texinfo et Texi2HTML.

Le choix d'installer des logiciels hors gestionnaire de paquets devrait
se faire lorsqu'on a besoin d'une version ou d'optiosn de compilation
spécifiques, et non pas pour cacher un bogue d'empaquetage. Sur Fedora
11 (et 12 depuis ce soir), je n'ai aucun problème pour avoir Texi2HTML
depuis les dépôts officiels.

John

···

Le samedi 21 novembre 2009 à 23:29 +0100, Valentin Villenave a écrit :

Astuce : il est beaucoup plus simple d'installer texi2html
manuellement que de forcer l'installation de je ne sais quelle version
(en tout cas, j'ai personnellement renoncé à utiliser le texi2html de
ma distribution, que ce soit Arch, buntu ou Mandriva).

Ok, j'ai envoyé un mail aux adresses indiquées sur les pages idoines
de packages.debian.org, en tentant d'expliquer le souci du mieux que
j'ai pu : on verra bien ce que ça donne. Si j'ai bien compris, en
attendant mieux, il faut que je me débrouille pour installer la
dernière version de texi2html hors gestionnaire de paquet car les deux
programmes sont nécessaires. J'ai réinstallé texinfo et la dernière
version de texi2html à partir des sources. Ça a l'air de s'être bien
passé :

$ texi2html --version
1.82
$

je retourne sous mon répertoire lilypond :
./autogen.sh, qui ne me retourne plus d'erreur :

Type:
    make all to build LilyPond
    make install to install LilyPond
    make help to see all possible targets

Edit local.make for local Makefile overrides.

là je me dit, on y arrive mais

$ make doc ou # make doc (je ne sais pas si seul root peut
le faire ou pas mais dans les deux cas l'erreur est la même)

retournent le message suivant :

Child returned 127
make[3]: *** [out-www/collated-files.texi] Error 1
make[3]: Leaving directory `/home/user/lilypond-web/lilypond/input/regression'
make[2]: *** [WWW-1] Error 2
make[2]: Leaving directory `/home/user/lilypond-web/lilypond/input'
make[1]: *** [WWW-1] Error 2
make[1]: Leaving directory `/home/user/lilypond-web/lilypond'
make: *** [doc-stage-1] Erreur 2

Je n'y comprends plus rien ....

NB : le répertoire de travail est /home/user/lilypond-web/lilypond

···

Le 21 novembre 2009 23:29, Valentin Villenave <****@****> a écrit :

2009/11/21 John Mandereau <****@****>:

C'est une erreur de la part des empaqueteurs de Debian : même en
remplaçant makeinfo par texi2html (ce qui est effectivement possible,
mais les empaqueteurs n'ont pas pris le soin de faire en sorte qu'un
lien symbolique de makeinfo vers texi2thml soit créé, d'où l'erreur
ci-dessous), texinfo contient texi2pdf, script pour lequel Texi2HTML ne
propose aucun remplacement. Bref, en attendant quelques semaines la
sortie de Texinfo 5, il faut installer à la fois Texinfo et Texi2HTML.

Astuce : il est beaucoup plus simple d'installer texi2html
manuellement que de forcer l'installation de je ne sais quelle version
(en tout cas, j'ai personnellement renoncé à utiliser le texi2html de
ma distribution, que ce soit Arch, buntu ou Mandriva).

Cordialement,
Valentin

Suite à mon message j'ai eu la réponse suivante :

I guess synaptic is a little bit careful here: you're taking the
version texi2html form unstable/testing(?) and try to install it on a
stable system. Meanwhile this is not always a good idea, I don't see
a problem here.
You just have to fulfil all depends of that package an can install
it: dpkg (>= 1.15.4) | install-info. No, I wouldn't replace dpkg, so
download install-info and texi2html from the web and download it
using dpkg.

As said, putting testing packahes on a stable system is not always
recommended, bug in this case it should not hurt.

pour les anglophobes de cette liste : en gros j'ai essayé d'installer
une autre version que celle proposée par défaut par la version stable
de debian, donc il décline toute responsabilité, ne compte rien y
faire, et me dis de me débrouiller à la main. Je comprends sa
position. Ça ne me donne cependant pas l'ombre d'une piste pour
compiler la doc ... oinnnn

pour les anglophobes de cette liste : en gros j'ai essayé d'installer
une autre version que celle proposée par défaut par la version stable
de debian, donc il décline toute responsabilité, ne compte rien y
faire, et me dis de me débrouiller à la main. Je comprends sa
position. Ça ne me donne cependant pas l'ombre d'une piste pour
compiler la doc ... oinnnn

Ca veut dire réinstalle les paquets par défaut de ta distribution
(remets ceux qui ont été enlevés) puis installe à la main la version
1.82 de texi2html à partir des sources :
tu télécharges les sources au format .tar.bz2 ou .tar.gz et puis :
$ tar xvfj fichier.tar.bz2 ou tar xvfz fichier.tar.gz
$ cd répertoire créé
$ ./configure
$ ./make
$ ./make install

voilà ! C'est ce que j'ai fait sous ubuntu et ça a marché.

Frédéric

Ca veut dire réinstalle les paquets par défaut de ta distribution
(remets ceux qui ont été enlevés) puis installe à la main la version
1.82 de texi2html à partir des sources :
tu télécharges les sources au format .tar.bz2 ou .tar.gz et puis :
$ tar xvfj fichier.tar.bz2 ou tar xvfz fichier.tar.gz
$ cd répertoire créé
$ ./configure
$ ./make
$ ./make install

voilà ! C'est ce que j'ai fait sous ubuntu et ça a marché.

Frédéric

Moi pas, je ne comprends pas pourquoi. J'ai toujours le même message
d'erreur. La commande make all a l'air de fonctionner par contre, ça
fait 10 minutes que ça tourne sans s'arrêter. Si ça fonctionne ce sera
déjà un progrès mais pas complètement satisfaisant car je suppose que
ça doit compiler bien plus que la simple doc en html.

là je me dit, on y arrive mais

$ make doc ou # make doc (je ne sais pas si seul root peut
le faire ou pas mais dans les deux cas l'erreur est la même)

On ne compile jamais un programme en root. Pour réparer cette horreur :

cd RÉPERTOIRE_RACINE_DE_COMPILATION
find -uid 0 |xargs rm -f

retournent le message suivant :

Child returned 127

C'est dommage de ne pas nous avoir fait connaître la ligne juste
au-dessus de celle-ci, qui contient probablement le vrai message
d'erreur, est-ce que ce serait quelque chose comme "Program not found" ?

On ne compile jamais un programme en root,
John

···

Le dimanche 22 novembre 2009 à 15:37 +0100, Michel Villeneuve a écrit :

Non, make sans cible explicite ne compile pas la doc (et prend
d'ailleurs bien moins de temps), mais les programmes binaires de
LilyPond, qui sont nécessaires à la compilation de la doc, sauf si on
compile avec EXTERNAL_BINARY. Je viens de voir dans le Guide du
contributeur que cette information n'est pas explicitement présente, je
vais l'ajouter.

Bonne compilation,
John

···

Le dimanche 22 novembre 2009 à 21:50 +0100, Michel Villeneuve a écrit :

Moi pas, je ne comprends pas pourquoi. J'ai toujours le même message
d'erreur. La commande make all a l'air de fonctionner par contre, ça
fait 10 minutes que ça tourne sans s'arrêter. Si ça fonctionne ce sera
déjà un progrès mais pas complètement satisfaisant car je suppose que
ça doit compiler bien plus que la simple doc en html.

On ne compile jamais un programme en root. Pour réparer cette horreur :

Promis, je ne le ferai plus.
A force de bricoler dans tous les sens, je me retrouve dans une
situation un peu bâtarde où synaptic m'indique que la version 1.78 est
installée mais en fait quand je demande la version à texi2html il me
renvoie 1.82. Mais du coup, ça compile :slight_smile:

cd RÉPERTOIRE_RACINE_DE_COMPILATION
find -uid 0 |xargs rm -f

Il me reste donc à faire un peu de ménage pour réparer mes bêtises.

retournent le message suivant :

Child returned 127

C'est dommage de ne pas nous avoir fait connaître la ligne juste
au-dessus de celle-ci, qui contient probablement le vrai message
d'erreur, est-ce que ce serait quelque chose comme "Program not found" ?

Non ce n'était pas Program not found, peut-être une sortie de dossier
"exit directory / ..." qui ne me semblait pas problématique, à
tord visiblement.

Morale de l'histoire :

* ne pas hésiter à installer à la main un programme qui n'est pas
proposé ou mal géré par son gestionnaire de paquet dans une version
non supportée si elle est absolument nécessaire,
.
* Ne pas essayer de compiler non plus avec une version pour laquelle
la doc explique que ça ne va pas marcher,

* Ne jamais compiler en root.

Merci beaucoup :slight_smile:

Bonjour,

j'ai installé Xubuntu sur un vieux portable qui n'a pas de carte réseau, avec lequel je communique
uniquement par clé usb.

Avec quelques difficultés, j'ai installé jEdit 4.3pre18 et ça tourne
(j'ai même installé les traductions françaises dans properties).

maintenant, pour installer Lilypond :
sur le site de référence, on me dit que lilypond fait partie de la distribution,
mais je n'en crois pas un mot : ( whereis lilypond => rien)
Je cherche un paquet complet, car j'ai trouvé un
lilypond_2.12.2-1ubuntu1_i386.deb qui plante : "dépendance non satisfaite : guile-1.8"
alors que j'ai bien un dossier 1.8 dans /usr/share/guile

Et il restera à installer Lilypondtool, toujours sans connexion Internet.

Quelqu'un voit où est le problème ?
Merci de votre aide
J.P. LANQUETIN

···

------------------------------------------------------------------------

_______________________________________________
liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-user-fr

Loin de moi l'idée de faire de l'auto-promotion, mais ce modeste
tutoriel vidéo peut-il être de quelque utilité ?
http://lpreport.blip.tv/file/2536818/

Cordialement,
Valentin

···

2009/11/23 jp lanquetin <****@****>:

maintenant, pour installer Lilypond :
sur le site de référence, on me dit que lilypond fait partie de la
distribution,

Merci de ne pas commencer un nouveau sujet en répondant à un message
précédent, ça embrouille le tri des messages par fil de discussion.

maintenant, pour installer Lilypond :
sur le site de référence, on me dit que lilypond fait partie de la
distribution,
mais je n'en crois pas un mot : ( whereis lilypond => rien)
Je cherche un paquet complet, car j'ai trouvé un
lilypond_2.12.2-1ubuntu1_i386.deb qui plante : "dépendance non
satisfaite : guile-1.8"
alors que j'ai bien un dossier 1.8 dans /usr/share/guile

Je ne sais pas comment est empaqueté Guile sous Ubuntu, mais sous Fedora
il existe deux paquets guile et guile-lib, et il semble que les deux
soient nécessaires à LilyPond d'après le message d'erreur ci-dessus. Vu
la modularité des paquets de n'importe quelle distribution de GNU/Linux
qui se respecte et le nombre de dépendances de LilyPond, il est
impensable d'espérer trouver un paquet complet avec Guile, Pango,
fonctconfig... c'est une des raisons pour lesquelles des paquets pour
Linux, contenant toutes les dépendances (sauf la bibliothèque C), sont
proposés sur lilypond.org.

Et il restera à installer Lilypondtool, toujours sans connexion Internet.

Une solution est d'installer JEdit et LilyPondTool sur une machine avec
Internet, puis de copier le dossier .jedit (qui contient notamment les
plugins téléchargés, LilyPondTool et ses dépendances) vers le vieux
portable.

Salutations lilyesques,
John

···

Le lundi 23 novembre 2009 à 17:44 +0100, jp lanquetin a écrit :

Comme l'a mentionné John, l'installeur de LilyPond peut très bien se
transporter sur une clé USB :
http://lilypond.org/web/install/

Je transporte toujours sur moi une clé USB incluant :
- les installeurs LilyPond Windows, Mac et GNU/Linux
- un installeur Java pour Windows au cas où
- jEdit en version Windows, .deb et .jar
- mon dossier .jedit prêt à l'emploi (sur toutes plateformes),
incluant tous les plugins et réglages qui vont bien.

Cordialement,
Valentin

···

2009/11/24 jp lanquetin <****@****>:

Merci, j'avais déjà visionné ce tuto
mais comme mon PC n'a pas de connexion Internet,
le script d'installation ne convient pas
je cherche un paquet copiable via clé USB.

Valentin Villenave a écrit :

  
Comme l'a mentionné John, l'installeur de LilyPond peut très bien se
transporter sur une clé USB :
http://lilypond.org/web/install/

Je transporte toujours sur moi une clé USB incluant :
- les installeurs LilyPond Windows, Mac et GNU/Linux
- un installeur Java pour Windows au cas où
- jEdit en version Windows, .deb et .jar
- mon dossier .jedit prêt à l'emploi (sur toutes plateformes),
incluant tous les plugins et réglages qui vont bien.

D'accord, cette solution fonctionne :
j'ai copié le .jedit de mon PC windows sur mon portable Unix
et LilypondTool est disponible .

MAIS :
impossible de compiler un fichier .ly : car il cherche "C:/programfiles\ lilypond\usr\bin /lilypond"
alors que bien sûr cela se trouve dans "home/jp/lilypond/usr/bin"
Où faut-il modifier le chemin ?
(j'ai trouvé dans un forum que c'était dans Plugin > développement> lilypond options > lilypondTool> général> path to lily bin,
mais cela ne correspond pas à mes menus contextuels)

De plus, dans mon fichier .ly, avec jEdit, tous les "do" sont en gras et en vert ( paramètres du KEYWORD2 )
ce que je n'avais pas avec les versions antérieures de jEdit.
Je ne trouve pas où règler ce (petit) défaut.

Merci de votre aide.
JiPé

···

2009/11/24 jp lanquetin <****@****>:

Cordialement,
Valentin

impossible de compiler un fichier .ly : car il cherche "C:/programfiles\
lilypond\usr\bin /lilypond"
alors que bien sûr cela se trouve dans "home/jp/lilypond/usr/bin"
Où faut-il modifier le chemin ?

Plugins > Plugin options > Commandes > la case du haut.

(c'est indiqué dans mon tutoriel je crois)

De plus, dans mon fichier .ly, avec jEdit, tous les "do" sont en gras et en
vert ( paramètres du KEYWORD2 )
ce que je n'avais pas avec les versions antérieures de jEdit.
Je ne trouve pas où règler ce (petit) défaut.

C'est que votre fichier est interprété comme du C++ ou du basic ou (en
tout cas) certainement pas du code Lilypond. Votre extension est-elle
bien .ly ?

Cordialement,
Valentin

···

2009/11/25 jp lanquetin <****@****>: