Erreur Fatale

Bonjour à tous,

J'ai un problème Lilypond ne veut plus ouvrir mes partitions.

Voilà l'erreur que j'obtiens :

Avertissement : échec de « (gs -q -dSAFER -dDEVICEWIDTHPOINTS=595.28 -dDEVICEHEIGHTPOINTS=841.89 -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite -dAutoRotatePages=/None -dPrinted=false -sOutputFile=SCORE.pdf -c.setpdfwrite -f/tmp/lilypond-XRnM78) » (11)

Merci de votre aide !

Clément Caillol

Bonjour,

Sous Windows, on a souvent vu cette erreur lorsque le fichier PDF
généré par LilyPond était resté ouvert lors de la deuxième compilation.
Contrairement aux systèmes fondés sur le noyau Linux ou à Mac OS,
Windows n'est pas capable de gérer la situation où un fichier est
modifié sur le disque alors qu'il est ouvert. Essayez de fermer le
PDF et de recommencer. Je recommande très vivement l'éditeur
Frescobaldi qui vous évitera ces peines (et je ne suis pas le
seul à l'apprécier sur cette liste).

Si le problème n'est pas lié à cette subtilité, il faudra plus
d'informations pour comprendre : quel est votre système ? Version
de LilyPond ? Comment l'avez-vous installé ?

Cordialement,
Jean

···

Le 26/10/2020 à 19:29, Clement Caillol a écrit :

Bonjour à tous,

J'ai un problème Lilypond ne veut plus ouvrir mes partitions.

Voilà l'erreur que j'obtiens :

Avertissement : échec de « (gs -q -dSAFER -dDEVICEWIDTHPOINTS=595.28 -dDEVICEHEIGHTPOINTS=841.89 -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite -dAutoRotatePages=/None -dPrinted=false -sOutputFile=SCORE.pdf -c.setpdfwrite -f/tmp/lilypond-XRnM78) » (11)

Merci de votre aide ! Clément Caillol

Bonjour, merci !

Cependant, je suis sous linux et utilise frescobaldi.

Je suis sous Librazik 3 (Debian 10) et j'utilise lilypond 2.20.

Bien cordialement,

Clément Caillol

···

Le 26/10/2020 à 20:13, Jean Abou Samra a écrit :

Le 26/10/2020 à 19:29, Clement Caillol a écrit :

Bonjour à tous,

J'ai un problème Lilypond ne veut plus ouvrir mes partitions.

Voilà l'erreur que j'obtiens :

``

Avertissement : échec de « (gs -q -dSAFER -dDEVICEWIDTHPOINTS=595.28 -dDEVICEHEIGHTPOINTS=841.89 -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite -dAutoRotatePages=/None -dPrinted=false -sOutputFile=SCORE.pdf -c.setpdfwrite -f/tmp/lilypond-XRnM78) » (11)

``

``

``

``

`Merci de votre aide !

Clément Caillol`

Bonjour,

Sous Windows, on a souvent vu cette erreur lorsque le fichier PDF
généré par LilyPond était resté ouvert lors de la deuxième compilation.
Contrairement aux systèmes fondés sur le noyau Linux ou à Mac OS,
Windows n'est pas capable de gérer la situation où un fichier est
modifié sur le disque alors qu'il est ouvert. Essayez de fermer le
PDF et de recommencer. Je recommande très vivement l'éditeur
Frescobaldi qui vous évitera ces peines (et je ne suis pas le
seul à l'apprécier sur cette liste).

Si le problème n'est pas lié à cette subtilité, il faudra plus
d'informations pour comprendre : quel est votre système ? Version
de LilyPond ? Comment l'avez-vous installé ?

Cordialement,
Jean

``

Bonjour,

C'est un problème que l'on a vu passer de temps en temps.

Avez-vous installé LilyPond par le gestionnaire de paquets du système ? Si oui, pourriez-vous essayer les scripts sh fournis sur le site officiel à la place ?

Si non, avez-vous fait quelque chose comme

https://lists.gnu.org/archive/html/lilypond-user/2020-04/msg00347.html

c'est à dire donné à Frescobaldi un chemin du type /.../lilypond-.../usr/bin/lilypond au lieu de /.../lilypond-.../bin/lilypond ?

Et si cela ne marche toujours pas, le problème se reproduit-il en ligne de commande ? Quel est le chemin de l'exécutable (commande « which lilypond ») et quelle est la sortie en mode verbeux (« lilypond --verbose fichier.ly ») ?

Merci,
Jean

···

Le 26/10/2020 à 20:58, Clement Caillol a écrit :

Bonjour, merci !

Cependant, je suis sous linux et utilise frescobaldi.

Je suis sous Librazik 3 (Debian 10) et j'utilise lilypond 2.20.

Bien cordialement,

Clément Caillol

Bonjour,

Probleme résolu, merci !
J'ai désinstallée lilypond 2.18 de mon système, et réinstallé la 2.20.

Du coup j'ai eu le bon raccourci dans ~/bin

Ça a résolu le problème.

Merci !

Clément Caillol

···

From: Jean Abou Samra <****@****>
Sent: Monday, October 26, 2020 11:40:05 PM
To: Clement Caillol <****@****>; lilypond-user-fr@gnu.org lilypond-user-fr@gnu.org
Subject: Re: Erreur Fatale

Le 26/10/2020 à 20:58, Clement Caillol a écrit :

Bonjour, merci !

Cependant, je suis sous linux et utilise frescobaldi.

Je suis sous Librazik 3 (Debian 10) et j'utilise lilypond 2.20.

Bien cordialement,

Clément Caillol

Bonjour,

C'est un problème que l'on a vu passer de temps en temps.

Avez-vous installé LilyPond par le gestionnaire de paquets du système ?
Si oui, pourriez-vous essayer les scripts sh fournis sur le site
officiel à la place ?

Si non, avez-vous fait quelque chose comme

https://lists.gnu.org/archive/html/lilypond-user/2020-04/msg00347.html

c'est à dire donné à Frescobaldi un chemin du type
/.../lilypond-.../usr/bin/lilypond au lieu de
/.../lilypond-.../bin/lilypond ?

Et si cela ne marche toujours pas, le problème se reproduit-il en ligne
de commande ? Quel est le chemin de l'exécutable (commande « which
lilypond ») et quelle est la sortie en mode verbeux (« lilypond
--verbose fichier.ly ») ?

Merci,
Jean