erreur lors de l'installation de lilypond

Bonjour

Je tente de (ré)installer Lilypond et j'obtiens le message suivant;

Le fichier pdf /tmp/lilypond-cFudBf a été créé

Une piste pour la correction de cette erreur m'aiderait .

Cordialement

Michel

C'est certainement parce que test.pdf est déjà ouvert avec Acrobat Reader ou équivalent pendant la compilation. du coup le programme gs (Ghostscript) n'arrive pas à ouvrir test.pdf en écriture.
cordialement
Jean-Paul Quelen

···

Le 16/04/2020 à 21:37, MGmail a écrit :

Bonjour

Je tente de (ré)installer Lilypond et j'obtiens le message suivant;

Le fichier pdf /tmp/lilypond-cFudBf a été créé

Une piste pour la correction de cette erreur m'aiderait .

Cordialement

Michel

Je ne suis pas sûr que cela marche comme ça sous GNU/Linux ; en
principe l’inode reste accessible, ce qui permet justement au PDF
ouvert dans une visionneuse de se mettre à jour en temps réel.

Le problème de Michel est un classique, qui peut avoir plein de
raisons différentes mais je commencerais par mettre à jour ou
réinstaller GhostScript, qui est notoirement erratique.

V.

···

On 4/16/20, Jean-Paul Quelen <****@****> wrote:

C'est certainement parce que test.pdf est déjà ouvert avec Acrobat
Reader ou équivalent pendant la compilation. du coup le programme gs
(Ghostscript) n'arrive pas à ouvrir test.pdf en écriture.

Tiens, il semble qu’effectivement vous ne soyez pas le seul à être
tombé sur ce problème :
https://lists.gnu.org/archive/html/lilypond-user/2020-04/msg00301.html

À tous les coups vous devez avoir du GhostScript 9.21 qui traine quelque part.

V.

···

On 4/17/20, Valentin Villenave <****@****> wrote:

Le problème de Michel est un classique, qui peut avoir plein de
raisons différentes mais je commencerais par mettre à jour ou
réinstaller GhostScript, qui est notoirement erratique.

Comment lancez-vous LilyPond ? Avez-vous essayé de simplement lancer

  cd mon_dossier_lilypond/
  lilypond monfichier.ly

dans un terminal pour voir si le problème se reproduit ?

Si vous utilisez Frescobaldi, allez dans les Préférences pour vérifier
que la commande indiquée (et le chemin) est bien

  lilypond

tout court, et non pas quelque chose comme

  /usr/local/lilypond/usr/bin/lilypond

(ce qui expliquerait votre problème).

Cordialement,
V. V.

···

On 4/20/20, MGmail <****@****> wrote:

Synaptic m'indqiue que la seule version installée est la 9.26....
Donc je n'ai pas résolu mon pb d'install de Lilypond

message reçu La commande « lilypond » n'a pas été trouvée, mais peut être
installée avec :
sudo apt install lilypond

Ah bin voilà, déjà il faudrait commencer par là. Plutôt que de faire
ce que vous conseille Ubuntu/Mint/Debian, je vous suggère plutôt
d’utiliser un installeur plus récent, à télécharger sur
http://lilypond.org/unix.html par exemple.

Cela vous épargnera les histoires de dépendances etc.

Quand à Frescobaldi je l'ai désinstallé quand Lilypond a cessé de
fonctionner; je voulais upgrader Frescobaldi

Vous pouvez toujours réinstaller Frescobaldi (avec les dépôts de votre
distribution ou en utilisant pip si vous savez faire).

De mémoire le chemin comportait le chemin de la version 2.18 de lilypond (et
cela fonctionnait)
et j'avais ajouté le chemin vers Lilypond
/usr/local/lilypond/usr/bin/lilypond+release

Non, justement ce n’est vraiment pas ce chemin là qu’il vaut mieux
utiliser, mais tout simplement "lilypond", ou
"/usr/local/bin/lilypond" s’il faut vraiment indiquer un chemin. Cela
devrait régler votre problème d’incompatibilité GhostScript.

Cordialement,
V. V.

···

On 4/20/20, MGmail <****@****> wrote:

Bonsoir

C'est ok, un grand merci

après la commande sh du paquet téléchargé depuis la page de lilypond

il a fallu faire:

~/bin$ sudo apt install lilypond

La commande lilypond est installée et le test lilypond test.ly produit le pdf etc..

Enfin réinstall de Frescobaldi par

sudo apt-get install frescobaldi

le chemin de Frescobaldi vers lilypond est

/home/mg/lilypond/usr/bin/lilypond

ceci s'est fait automatiquement et cela fonctionne

Bien cordialement

Michel

···

Le 20/04/2020 à 23:08, Valentin Villenave a écrit :

On 4/20/20, MGmail <****@****> wrote:

message reçu La commande « lilypond » n'a pas été trouvée, mais peut être
installée avec :
sudo apt install lilypond

Ah bin voilà, déjà il faudrait commencer par là. Plutôt que de faire
ce que vous conseille Ubuntu/Mint/Debian, je vous suggère plutôt
d’utiliser un installeur plus récent, à télécharger sur
http://lilypond.org/unix.html par exemple.

Cela vous épargnera les histoires de dépendances etc.

Quand à Frescobaldi je l'ai désinstallé quand Lilypond a cessé de
fonctionner; je voulais upgrader Frescobaldi

Vous pouvez toujours réinstaller Frescobaldi (avec les dépôts de votre
distribution ou en utilisant pip si vous savez faire).

De mémoire le chemin comportait le chemin de la version 2.18 de lilypond (et
cela fonctionnait)
et j'avais ajouté le chemin vers Lilypond
/usr/local/lilypond/usr/bin/lilypond+release

Non, justement ce n’est vraiment pas ce chemin là qu’il vaut mieux
utiliser, mais tout simplement "lilypond", ou
"/usr/local/bin/lilypond" s’il faut vraiment indiquer un chemin. Cela
devrait régler votre problème d’incompatibilité GhostScript.

Cordialement,
V. V.