Fichiers temporaires linux

J'ai des soucis avec lilypond sous Ubuntu.
1- comment le lancer d'un simple clic
2- comment gérer la masse de fichiers temporaires.
Y a-t-il un "how to " à c sujet?

Merci
PC

Bonjoir !

Pierre Couderc a écrit :

J'ai des soucis avec lilypond sous Ubuntu.
1- comment le lancer d'un simple clic

Je ne pense pas que ce soit possible, lilypond attend en argument un nom de fichier valide.
On le lance donc par une ligne de commande du type :

lilypond fichiermusical.ly

Mais si tu utilises aussi jedit (correctement configuré), il te suffit de lancer jedit (par simple clic, donc) et de choisir par la suite sur quel fichier tu veux travailler.

2- comment gérer la masse de fichiers temporaires.

Je ne comprends pas la question. De quels fichiers temporaires parles-tu ?
Lilypond génère des fichiers pdf, midi, et ps en général, ainsi que des ficiers de sauvegarde, si je ne m'abuse, mais ce ne sont pas des fichiers temporaires au sens strict...

Cordialement,

Philippe.

Le jeudi 15/12/11 à 19h46,

···

Le Piaf <****@****> a écrit :

Mais si tu utilises aussi jedit

Ou Frescobaldi, vraiment très pratique :

--
Denis

Re !

Denis Bitouzé a écrit :

Ou Frescobaldi, vraiment très pratique :

http://frescobaldi.org/
  

Ah, désolé d'avoir oublié Frescobaldi :

1°) Étant sous Debian (Lenny), Jedit est fourni dans les dépôts "stable" de ma distribution préférée.
2°) Préférant l'environnement Gnome, je ne peux utiliser frescobaldi, qui tourne sous KDE.
3°) Jedit peut permettre de travailler avec d'autres programmes que lilypond (programmation en de très nombreux langages, compilateurs, etc.).
4°) Jedit fonctionne sur toutes les architectures possédant une machine viruelle java 2 1.3 minimum (donc sous les Winchose, MACOS, Linux(es), VMS, et UNIX.)

Voilà pourquoi j'ai spontanément cité Jedit.

Tout ceci bien sûr sans rien présumer de la qualité de Frescobaldi, qui doit être de très bonne qualité, si j'en juge par le nombre de gens qui l'utilisent et qui en parlent sur cette mailing list.
D'autant que d'après ce que j'ai lu, Frescobaldi étant fait pour utiliser Lilypond, il en rend probablement l'utilisation plus confortable (écouter le morceau qu'on vient d'écrire sans avoir à passer par la ligne de commande par exemple.)

Lilypondiennement,

Philippe

Le jeudi 15/12/11 à 22h54,

2°) Préférant l'environnement Gnome, je ne peux utiliser frescobaldi,
qui tourne sous KDE.

Euh... si, tu peux :wink: Il te faudra peut-être installer quelques
bibliothèques et autres dépendances, mais ça sera possible. Ici, sous
KDE, je fais tourner certains programmes développés pour Gnome.

3°) Jedit peut permettre de travailler avec d'autres programmes que
lilypond (programmation en de très nombreux langages, compilateurs,
etc.).

C'est vrai, je préfère moi aussi les éditeurs généralistes mais cf.
plus bas.

4°) Jedit fonctionne sur toutes les architectures possédant
une machine viruelle java 2 1.3 minimum (donc sous les Winchose,
MACOS, Linux(es), VMS, et UNIX.)

Voilà pourquoi j'ai spontanément cité Jedit.

Tout ceci bien sûr sans rien présumer de la qualité de Frescobaldi,
qui doit être de très bonne qualité, si j'en juge par le nombre de
gens qui l'utilisent et qui en parlent sur cette mailing list.
D'autant que d'après ce que j'ai lu, Frescobaldi étant fait pour
utiliser Lilypond, il en rend probablement l'utilisation plus
confortable (écouter le morceau qu'on vient d'écrire sans avoir à
passer par la ligne de commande par exemple.)

J'ai testé Jedit sous Windows pour initier un copain à LilyPond et,
pour l'aperçu que j'en ai eu, je trouve effectivement Frescobaldi plus
ergonomique, plus pratique.

···

Le Piaf <****@****> a écrit :
--
Denis

Merci pour toutes les réponses mais j'en espère d'autres....

Bonjoir !

Pierre Couderc a écrit :

J'ai des soucis avec lilypond sous Ubuntu.
1- comment le lancer d'un simple clic

Je ne pense pas que ce soit possible, lilypond attend en argument un nom de fichier valide.
On le lance donc par une ligne de commande du type :

lilypond fichiermusical.ly

Bon, j'espère que c'est possible. C'est possible sous Windows , ce doit être possible sous linux, sinon cela voudrait dire que linux est moins bon, ce que je ne crois pas. Je suis sur la piste de nautilus-scripts

Mais si tu utilises aussi jedit (correctement configuré), il te suffit de lancer jedit (par simple clic, donc) et de choisir par la suite sur quel fichier tu veux travailler.

Bon, je n'aime pas trop jedit ni frescobaldi...
Au surplus, j'ai u bug avec frscobamdi.
Mon idée, c'est clic normal compile, et clic droite permet de choisir en particulier l'éditeur.

2- comment gérer la masse de fichiers temporaires.

Je ne comprends pas la question. De quels fichiers temporaires parles-tu ?
Lilypond génère des fichiers pdf, midi, et ps en général, ainsi que des ficiers de sauvegarde, si je ne m'abuse, mais ce ne sont pas des fichiers temporaires au sens strict...

Mmm, je dois avoir 6 fichers bidons générés, je me moque de midi,seul .pdf m'interesse, et je ne veux pas ces fichiers parasites qui polluent mon directory. C'est inaccceptable comme méthode de travail. Il faut que j'arrivee à trouver une sluiton propres, j'ai 200 sources à gérer...
D'ailleurs la version windows est plus propre.

Merci encore pour le soutien.

···

On 15/12/2011 19:46, Le Piaf wrote:

Tu utilises quel version de LilyPond (sous GNU/Linux) ?
Le MIDI n'est généré que si tu as un bloc \midi dans ton fichier .ly .
Et le .ps est supprimé dès qu'il est converti en PDF (versions >2.12).
Donc au final il ne doit te rester que le PDF (et le .ly qui reste) !

Cordialement,
Xavier

···

2011/12/16 Pierre Couderc <****@****>:

Mmm, je dois avoir 6 fichers bidons générés, je me moque de midi,seul .pdf
m'interesse, et je ne veux pas ces fichiers parasites qui polluent mon
directory. C'est inaccceptable comme méthode de travail. Il faut que
j'arrivee à trouver une sluiton propres, j'ai 200 sources à gérer...
D'ailleurs la version windows est plus propre.

--
Xavier Scheuer <****@****>

Merci Xavier,
J'utilise ce que je trouve sous mon ubuntu 11.11 à savoir 2.12.3
avec :
lilypond test.ly
on m'informe gentiment que j'aurais du taper :
lilypond -sbackend=eps lilypond.ly

Pas contrariant, je m'xécute.
Il me crée, accrochez-vous :
test-1.eps
test-1.pdf
test.eps
test.pdf
test-systems.count
test-systems.tex
test-systems.texi
Sûr, j'ai mon .pdf, mais à quel prix!...

···

Le 16/12/2011 00:20, Xavier Scheuer a écrit :

2011/12/16 Pierre Couderc<****@****>:

Mmm, je dois avoir 6 fichers bidons générés, je me moque de midi,seul .pdf
m'interesse, et je ne veux pas ces fichiers parasites qui polluent mon
directory. C'est inaccceptable comme méthode de travail. Il faut que
j'arrivee à trouver une sluiton propres, j'ai 200 sources à gérer...
D'ailleurs la version windows est plus propre.

Tu utilises quel version de LilyPond (sous GNU/Linux) ?
Le MIDI n'est généré que si tu as un bloc \midi dans ton fichier .ly .
Et le .ps est supprimé dès qu'il est converti en PDF (versions>2.12).
Donc au final il ne doit te rester que le PDF (et le .ly qui reste) !

Cordialement,
Xavier

Bonjour,

La première chose à faire serait, à mon sens, de passer à la dernière
version stable, 2.14.2. Malheureusement, elle ne se trouve pas toujours sur
les dépôts Linux, il vaut mieux télécharger l'installeur depuis le site de
lilypond.

Avec la version 2.14, pas besoin de "backend" ou autre la simple commande :

lilypond monfichier.ly

produira un pdf et rien d'autre.

J'avoue que j'ignore comment fonctionnent les dépôts Linux (étant sur une
autre plateforme), mais je suis étonné que la version 2.12 y soit encore
proposée alors que la 2.14 est sortie il y a de longs mois (juin).

Philippe

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fichiers-temporaires-linux-tp7098040p7100107.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Bonjour,

flup a écrit :

Bonjour,

J'avoue que j'ignore comment fonctionnent les dépôts Linux (étant sur une
autre plateforme), mais je suis étonné que la version 2.12 y soit encore
proposée alors que la 2.14 est sortie il y a de longs mois (juin).

Philippe

Sous Debian par exemple, on privilégie la sécurité : les programmes sont testés pour voir s'il n'ont pas de failles de sécurité, de bugs trop gênants, etc., avant d'être ajoutés aux différents dépôts (sauf peut-être pour la branche "unstable", qui n'est pas recommandée pour une utilisation "en production").

Donc un utilisateur Debian préférera attendre que la version soit dans les dépôts, plutôt que de télécharger une version qui compromettrait sa sécurité.

C'est un choix.

Sous Ubuntu, la politique n'étant pas la même, on préfère avoir les paquets dans les dépôts
même s'ils ne sont pas complètement au point, mais avoir la dernière version, ou au moins la plus récente possible, au détriment de la sécurité, ou du fonctionnement.

C'est aussi un choix.

Et il faut se souvenir que pour les dépôts Debian (dont dépendent Ubuntu, qui est basé dessus), ce sont de très généreux bénévoles qui font le travail de développement, et qui prennent sur leur temps pour nous livrer des paquets. Merci à eux.

Voilà ce que je pouvais dire sur les dépôts Debian/Ubuntu. Pour les autres distributions, je ne sais pas...

Voili voilou, j'espère que ça éclairera ta lanterne

Philippe

Mmm, y a-t-il un dépot non officiel debian ou ubuntu pour la 2.14?

···

Le 16/12/2011 10:08, flup a écrit :

Bonjour,

La première chose à faire serait, à mon sens, de passer à la dernière
version stable, 2.14.2. Malheureusement, elle ne se trouve pas toujours sur
les dépôts Linux, il vaut mieux télécharger l'installeur depuis le site de
lilypond.

Avec la version 2.14, pas besoin de "backend" ou autre la simple commande :

lilypond monfichier.ly

produira un pdf et rien d'autre.

J'avoue que j'ignore comment fonctionnent les dépôts Linux (étant sur une
autre plateforme), mais je suis étonné que la version 2.12 y soit encore
proposée alors que la 2.14 est sortie il y a de longs mois (juin).

Philippe

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Fichiers-temporaires-linux-tp7098040p7100107.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

_______________________________________________
liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user-fr

Pierre Couderc a écrit :

Mmm, y a-t-il un dépot non officiel debian ou ubuntu pour la 2.14?

Non officiel, je sais pas, mais dans les dépôts wheezy :

http://pkgs.org/search/?keyword=lilypond

D'autres distributions proposent déjà la 2.15...

Et pour les moins paranos, on peut toujours l'installer en la compilant soi-même ou en utilisant l'installateur ici :

http://lilypond.org/unix.fr.html

Cordialement,

Philippe

Mmm, je suis très parano, moi... ce n'est pas un PPA de 2.14 pour Ubuntu 11.10...
Je suis très conservateur...
Je vais tout simplement faire un script pour me débarrasser de ces fichiers pénibles...

Merci
PC

Notr : "répondre à la liste" ne fonctione pas chez moi...

Le 16/12/2011 12:11, Le Piaf a écrit :

···

Pierre Couderc a écrit :

Mmm, y a-t-il un dépot non officiel debian ou ubuntu pour la 2.14?

Non officiel, je sais pas, mais dans les dépôts wheezy :

http://pkgs.org/search/?keyword=lilypond

D'autres distributions proposent déjà la 2.15...

Et pour les moins paranos, on peut toujours l'installer en la compilant soi-même ou en utilisant l'installateur ici :

http://lilypond.org/unix.fr.html

Cordialement,

Philippe