Le Puzzle du Batteur - The Drummer's 'G'igsaw: UPDATE.

Bonsoir à tous,

Une mise à jour pour compatibilité avec Lilypond 2.14 est disponible:

http://superbonus.project.free.fr/spip.php?article44

Le Puzzle du Batteur - The Drummer's 'G'igsaw

···

*****

Éditeur polyrythmique pour Batterie et Percussions fondé sur Lilypond +
Interface graphique pour traitement aléatoire du timing et/ou du volume
midi.

                   ******

                 DÉPENDANCES

Vous devez installer :

GNU Lilypond >= 2.14.0
http://lilypond.org

midicomp 0.0.4
http://midicomp.opensrc.org/midicomp-0.0.4.tar.gz

Télécharger midicomp 0.0.4 puis, en console root, le déplacer vers
/usr/local (ou /usr) :
# mv /MON/CHEMIN/... /midicomp-0.0.4.tar.gz /usr/local (ou /usr)

Aller, toujours en root, dans /usr/local (ou /usr)
# cd /usr/local (ou /usr)

Décompresser le paquet :
# tar -zxvf midicomp-0.0.4.tar.gz

puis aller dans le nouveau dossier qui a été créé :
# cd /usr/local/midicomp-0.0.4 (ou /usr)

et taper (toujours en root) :
# make

En choisissant /usr le fichier binaire devrait être installé dans
/usr/bin automatiquement mais je crois que dans le cas de /usr/local
il faut déplacer ce fichier dans /usr/local/bin après la compile :
# mv /usr/local/midicomp-0.0.4/midicomp /usr/local/bin

Python 2.6.x avec l'option Tk activée à la compilation.
Par défaut dans votre distribution de Linux.
ou http://www.python.org/

GNU Bash, GNU awk et GNU sed.

Par défaut dans votre distribution de Linux.
J'utilise Timidity++ 2.13.2 avec eawpatches comme config par
défaut. (et sans reverb!!!)

                   ******

Ayez du bonheur.

Phil.