lilypond-book, TeXShop : erreur !

Bonjour à tous,
Je me réjouissais il y a peu que l'acquisition d'un nouvel ordinateur (MacBook) allait me permettre enfin d'utiliser LilyPond-book. D'autant plus qu'on m'a indiqué, sur cette même liste, un petit plug-in pour TeXShop qui permettait de compiler directement les fichiers .ly et même .lytex.
Las ! Aujourd'hui je me lance dans un fichier musique + texte, et... erreur !
LaTeX Error: File `/Users/loicchahine/Documents/recherche/Nouvelles parodies
bachiques/atys2-lily/51/lily-9ef7955c-4' not found.
Est-ce que quelqu'un a une idée ? Je vous mets en pièce jointe le fichier et le préambule.
Merci d'avance à ceux qui auront un peu de temps et beaucoup de courage pour y jeter un œil !
L.

atys2.lytex (1.84 KB)

preambule_npb.sty (5.33 KB)

D'abord, est-ce que tu peux vérifier que ta version de lilypond-book marche ?
Il faudrait que tu ailles à bachiques/atys2-lily dans le Terminal (qui se trouve normalement dans le dossier Applications/Utilitaires) et puis que tu tapes les commandes suivantes:

lilypond-book atys2.lytex
latex atys2.tex
dvips -Ppdf atys2
ps2pdf atys2.ps

Si ça ne marche pas, merci de nous signaler l'étape où ça part en sucette.

~Mike

···

On Mar 5, 2011, at 8:23 AM, Loïc Chahine wrote:

Bonjour à tous,
Je me réjouissais il y a peu que l'acquisition d'un nouvel ordinateur (MacBook) allait me permettre enfin d'utiliser LilyPond-book. D'autant plus qu'on m'a indiqué, sur cette même liste, un petit plug-in pour TeXShop qui permettait de compiler directement les fichiers .ly et même .lytex.
Las ! Aujourd'hui je me lance dans un fichier musique + texte, et... erreur !
LaTeX Error: File `/Users/loicchahine/Documents/recherche/Nouvelles parodies
bachiques/atys2-lily/51/lily-9ef7955c-4' not found.
Est-ce que quelqu'un a une idée ? Je vous mets en pièce jointe le fichier et le préambule.
Merci d'avance à ceux qui auront un peu de temps et beaucoup de courage pour y jeter un œil !
L.

Ça commence très mal : -bash: lilypond-book: command not found

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/lilypond-book-TeXShop-erreur-tp6091775p6091837.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Essaie de créer un fichier qui s'appelle .bash_profile dans ton dossier Maison et, dans ce fichier, mets:

export PATH=$PATH:/path/to/lilypond/bin (d'habitude c'est un truc du style /Applications/Lilypond.app/Contents/Resources/Version/Current/bin ... il faut que tu creuses un peu pour trouver le bon chemin).

Ensuite, ferme et relance le Terminal et réessaie lilypond-book.

Bon courage !
~Mike

···

On Mar 5, 2011, at 8:56 AM, Céladon wrote:

Ça commence très mal : -bash: lilypond-book: command not found

Je ne sais si cela sera utile, car je suis sur Linux/Gentoo mais je
réussis à compiler le fichier en changeant 2 choses:

1. Dans atys2.lytex j'ai dû mettre le chemin complet pour
\input{/home/......../preambule_npb.sty}

2. Dans preambule_npb.sty Latex ne trouve pas le package xstring.
C'est qu'il ne doit pas être installé chez moi.
J'ai donc commenté \usepackage{xstring}

Et j'obtiens le pdf.
Voici comment je procède (en console):
je vais dans le répertoire où se trouvent preambule_npb.sty et atys2.lytex
cd blabla
Dans ce répertoire j'ai créé 2 autres répertoires, côte à côte:
out-lily et out
puis je fais (en une seule ligne):
/usr/local/bin/lilypond-book --use-source-file-names
--lily-output-dir=out-lily --pdf --output=out atys2.lytex
puis:
cd out puis:
pdflatex atys2.tex
(Et pas atys2.lytex cette 2ème fois)

Sur Mac je ne sais pas si c'est valable.
En tout cas ça marche ici.
Phil.

···

Le 05/03/2011 14:23, Loïc Chahine a écrit :

Bonjour à tous,
Je me réjouissais il y a peu que l'acquisition d'un nouvel ordinateur
(MacBook) allait me permettre enfin d'utiliser LilyPond-book. D'autant
plus qu'on m'a indiqué, sur cette même liste, un petit plug-in pour
TeXShop qui permettait de compiler directement les fichiers .ly et même
.lytex.
Las ! Aujourd'hui je me lance dans un fichier musique + texte, et...
erreur !
LaTeX Error: File `/Users/loicchahine/Documents/recherche/Nouvelles
parodies
bachiques/atys2-lily/51/lily-9ef7955c-4' not found.
Est-ce que quelqu'un a une idée ? Je vous mets en pièce jointe le
fichier et le préambule.
Merci d'avance à ceux qui auront un peu de temps et beaucoup de courage
pour y jeter un œil !
L.

Pardon, visiblement mes messages ne sont pas arrivés jusqu'à la liste : Mike m'a aidé et le problème est résolu. En fait il ne faut pas d'espaces dans le chemin, et mon dossier en avait. Voilà.
Cela dit j'ai un nouveau (petit problème) : quand j'écris :
\parodair[D'une constance extrême]{l'Air}\nobreak
\begin{lilypond}
#(set-global-staff-size 18)
\include "atys-iv-constance.ly"
\end{lilypond}
(sachant que : \newcommand\parodair[2]{%
     \vspace{2ex}
     \begingroup
         \centering
         \emph{Sur #2}
         \ifx\empty#1\else\og{}#1\fg{}\fi%
         \par\nobreak
     \endgroup\nobreak
})
eh bien tous les nobreak sont ignorés... Quelqu'un a une idée ?