Mise à jour dernière version

Bonjour,

Mon Mac est en version OSX 11.6.7 (big sur), et je ne vois pas de version lilypond correspondant à mon ordi. J'ai actuellement la version 2.20 de Lily or je vois que la dernière version stabilisée est la 2.22.

Quelle version dois-je télécharger ?

Merci par avance,
Pascale

Voici ma version de Mac

···

Début du message réexpédié :

De: Pascale Petit <****@****>

Objet: Mise à jour dernière version

Date: 19 juillet 2022 à 20:46:12 UTC+2

À: lilypond-user-fr@gnu.org

Bonjour,

Mon Mac est en version OSX 11.6.7 (big sur), et je ne vois pas de version lilypond correspondant à mon ordi. J'ai actuellement la version 2.20 de Lily or je vois que la dernière version stabilisée est la 2.22.

Quelle version dois-je télécharger ?

Merci par avance,
Pascale

Bonjour,

La page me paraît mal formulée, ces paquetages non-officiels devraient normalement fonctionner sous macOS 10.15 ou supérieur, pas seulement sous macOS 10.15. Cela dit, ils ne vont que jusqu'à la version 2.20, donc n'apporteront rien dans votre cas. Malheureusement, il n'y a pas de version officielle 64-bits pour la version 2.22. Les choses sont en train de s'améliorer puisque la version instable actuelle, 2.23.10, possède bien un paquet 64-bits. Cependant, il faudra encore quelques mois avant qu'elle n'aboutisse à une version stable.

En attendant, si vous voulez mettre à jour vers 2.22, je suggère d'utiliser MacPorts. Il faut d'abord installer l'outil :

Apparemment, il faut aussi installer XCode, en tous cas c'est ce que je lis sur

https://guide.macports.org/#installing.xcode

Ensuite, il suffit de faire, dans un terminal,

sudo port install lilypond

Par contre, je ne sais pas si Frescobaldi va trouver la nouvelle version de LilyPond tout seul. Dites-le s'il ne le fait pas, ce sont des choses qui s'arrangent.

Cordialement,
Jean

···

Le 19/07/2022 à 20:46, Pascale Petit a écrit :

Bonjour,

Mon Mac est en version OSX 11.6.7 (big sur), et je ne vois pas de version lilypond correspondant à mon ordi. J'ai actuellement la version 2.20 de Lily or je vois que la dernière version stabilisée est la 2.22.

Quelle version dois-je télécharger ?

Bonjour, merci pour votre réponse. Après, ma version actuelle de lilypond fonctionne très bien et me convient. Donc, je ne vais rien changer pour le moment !
Bonne journée à vous,
Et merci
Pascale

···

Le mer. 20 juil. 2022 à 01:12, Jean Abou Samra <****@****> a écrit :

Le 19/07/2022 à 20:46, Pascale Petit a écrit :

Bonjour,

Mon Mac est en version OSX 11.6.7 (big sur), et je ne vois pas de
version lilypond correspondant à mon ordi. J'ai actuellement la
version 2.20 de Lily or je vois que la dernière version stabilisée est
la 2.22.

Quelle version dois-je télécharger ?

Bonjour,

La page me paraît mal formulée, ces paquetages non-officiels devraient
normalement fonctionner sous macOS 10.15 ou supérieur, pas seulement
sous macOS 10.15. Cela dit, ils ne vont que jusqu'à la version 2.20,
donc n'apporteront rien dans votre cas. Malheureusement, il n'y a pas de
version officielle 64-bits pour la version 2.22. Les choses sont en
train de s'améliorer puisque la version instable actuelle, 2.23.10,
possède bien un paquet 64-bits. Cependant, il faudra encore quelques
mois avant qu'elle n'aboutisse à une version stable.

En attendant, si vous voulez mettre à jour vers 2.22, je suggère
d'utiliser MacPorts. Il faut d'abord installer l'outil :

https://www.macports.org/install.php

Apparemment, il faut aussi installer XCode, en tous cas c'est ce que je
lis sur

https://guide.macports.org/#installing.xcode

Ensuite, il suffit de faire, dans un terminal,

sudo port install lilypond

Par contre, je ne sais pas si Frescobaldi va trouver la nouvelle version
de LilyPond tout seul. Dites-le s'il ne le fait pas, ce sont des choses
qui s'arrangent.

Cordialement,
Jean