Problème convert-ly.py

Bonjour,

Ayant installé sans problème la 2.10.1 sur WinXP, j'ai voulu convertir un des vieux fichiers .ly que j'avais fait avec la 1.4.12.

J'ai le problème illustré par la copie d'écran ci-dessus.

Quelqu'un a-t-il une idée ? Sans doute une erreur dans le source Python...

Yann
LilyPond 2.10.1 sur WinXP

convert-ly.py (GNU LilyPond) 2.10.0
Processing `soler_prelude_1.ly'...
Applying conversion: 1.3.147, 1.3.148, 1.5.33, 1.5.38, 1.5.40, 1.5.49, 1.5.52, 1
.5.56, 1.5.58, 1.5.59, 1.5.62, 1.5.67, 1.5.68, 1.5.71, 1.5.72, 1.6.5, 1.7.1, 1.7
.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.10, 1.7.11, 1.7.13, 1.7.15, 1.7.16, 1.7.17,
1.7.18, 1.7.19, 1.7.22, 1.7.23, 1.7.24, 1.7.28, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.9.
4, 1.9.5, 1.9.6, 1.9.7, 1.9.8, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.7, 2.1.10, 2.1.11
, 2.1.12, 2.1.13, 2.1.14, 2.1.15, 2.1.16, 2.1.17, 2.1.18, 2.1.19, 2.1.20, 2.1.21
, 2.1.22, 2.1.23, 2.1.24, 2.1.25, 2.1.26, 2.1.27, 2.1.28, 2.1.29, 2.1.30, 2.1.31
, 2.1.33, 2.1.34, 2.1.36, 2.2.0, 2.3.1, 2.3.2, 2.3.4, 2.3.6, 2.3.8, 2.3.9, 2.3.1
0, 2.3.11, 2.3.12, 2.3.16, 2.3.17, 2.3.18, 2.3.22, 2.3.23, 2.3.24, 2.4.0, 2.5.0,
2.5.1, 2.5.2, 2.5.3, 2.5.12, 2.5.13, 2.5.17, 2.5.18, 2.5.21, 2.5.25, 2.6.0, 2.7
.0, 2.7.1, 2.7.2, 2.7.4, 2.7.6, 2.7.10, 2.7.11, 2.7.12, 2.7.13, 2.7.14, Tracebac
k (most recent call last):
  File "c:\program files\lilypond\usr\bin\convert-ly.py", line 290, in ?
    main ()
  File "c:\program files\lilypond\usr\bin\convert-ly.py", line 284, in main
    do_one_file (f)
  File "c:\program files\lilypond\usr\bin\convert-ly.py", line 217, in do_one_fi
le
    (last, result) = do_conversion (infile.read (), from_version, to_version)
  File "c:\program files\lilypond\usr\bin\convert-ly.py", line 162, in do_conver
sion
    str = x[1] (str)
  File "c:\program files\lilypond\usr\share\lilypond\current\python\convertrules
.py", line 2636, in conv
    r"\\override \1VerticalAxisGroup #'extra-Y-extent")
TypeError: sub() takes at least 3 arguments (2 given)

D:\Mes Documents\Mes partitions\Fichiers_LilyPond>

C'est un bug connu et résolu dans la version 2.10.2. Je conseille à
tout le monde de vérifier régulièrement sur lilypond.org les mises à
jour de la version stable, non seulement pour les montagnes de bogues
corrigés mais aussi pour la traduction de la documentation (tutoriel
jusqu'à présent). La version stable actuelle est 2.10.9.

Salutations Lilyesques

···

Le dimanche 07 janvier 2007 à 11:51 +0100, Yann Morin a écrit :

Bonjour,

Ayant installé sans problème la 2.10.1 sur WinXP, j'ai voulu convertir
un des vieux fichiers .ly que j'avais fait avec la 1.4.12.

J'ai le problème illustré par la copie d'écran ci-dessus.

Quelqu'un a-t-il une idée ? Sans doute une erreur dans le source Python...

Yann
LilyPond 2.10.1 sur WinXP

--
John Mandereau <****@****>