Problème d'affichage avec Frescobaldi

Bonsoir à tous,

J'utilise Lilypond sous windows 7 avec la dernière version de Frescobaldi.
Après avoir installé la version 2.22.2, je me suis aperçu que le caractère "à" (a accent grave) placé en parole sous une note était soudainement devenu transparent et n'apparaissait plus sur la visualisation du pdf (et donc sur le fichier pdf généré au final). Le caractère occupe bien sa place mais il est invisible. À l'affichage, le rendu est comme si on avait remplacé le "à" par un \skip.

Dans l'exemple :
\relative c'' { c c c c }
\addlyrics { Il est à toi }

Rien n'apparaît sous la 3e noire et les paroles deviennent "Il est toi".

Le problème est rentré dans l'ordre dès que j'ai réinstallé la version 2.20.
Suis-je le seul à avoir ce problème ?

Bonne soirée à tous

Thierry

Bonsoir,

C'est un problème qui est revenu quelques fois (https://gitlab.com/lilypond/lilypond/-/issues/6216, https://gitlab.com/lilypond/lilypond/-/issues/6216). L'ennui est que Windows 7 est un système ancien, qu'aucun développeur de LilyPond ne possède pour pouvoir y faire du débogage, et qui n'est plus pris en charge par Microsoft depuis 2020. Je suis désolé de vous le dire, mais j'ai du mal à imaginer ce bug être réglé. D'ailleurs, les binaires des versions de développement actuelles (la série des 2.23, vouée à donner la prochaine version stable 2.24) utilisent Python 3.9, qui ne fonctionne pas non plus sous Windows 7, c'est à dire qu'il n'est pas possible d'exécuter les scripts Python fournis avec LilyPond, comme convert-ly, musicxml2ly et lilypond-book. D'après ce que j'ai pu comprendre, il serait encore possible de faire une mise à niveau vers Windows 10 gratuitement. Une autre possibilité, que je recommanderai toujours, est d'installer un système libre, par exemple Ubuntu, qui est d'après mon expérience très simple d'utilisation.

Bien cordialement,
Jean

···

Le 18/04/2022 à 22:23, ****@**** a écrit :

Bonsoir à tous,

J'utilise Lilypond sous windows 7 avec la dernière version de Frescobaldi.
Après avoir installé la version 2.22.2, je me suis aperçu que le caractère "à" (a accent grave) placé en parole sous une note était soudainement devenu transparent et n'apparaissait plus sur la visualisation du pdf (et donc sur le fichier pdf généré au final). Le caractère occupe bien sa place mais il est invisible. À l'affichage, le rendu est comme si on avait remplacé le "à" par un \skip.

Dans l'exemple :
\relative c'' { c c c c }
\addlyrics { Il est à toi }

Rien n'apparaît sous la 3e noire et les paroles deviennent "Il est toi".

Le problème est rentré dans l'ordre dès que j'ai réinstallé la version 2.20.
Suis-je le seul à avoir ce problème ?

Pas ce bug sous Xubuntu (Ubuntu avec une interface plus légère)

Je confirme pour (x)Ubuntu,

simple et à moins d'avoir des logiciels vraiment spécifiques, on peut tout faire.

···

Martial Rameaux

Bonjour à tous,

Ayant Windows 7, j'ai eu ce même problème et je l'avais signalé. Cela me donne en plus une erreur de type Warning et le caractère est remplacé par une espace.
Je n'ai pas eu la solution à ce problème qui, semble-t-il, ne se produit qu'avec ce caractère. Pourtant Lilypond et Frescobaldi travaillent avec des codes UTF8, "à" a son code qui est "c3 a0"... C'est peut-être le python sous-jacent qui pose problème.

Cordialement
Jean-Paul

···

Le 18/04/2022 à 22:23, ****@**** a écrit :

Bonsoir à tous,

J'utilise Lilypond sous windows 7 avec la dernière version de Frescobaldi.
Après avoir installé la version 2.22.2, je me suis aperçu que le caractère "à" (a accent grave) placé en parole sous une note était soudainement devenu transparent et n'apparaissait plus sur la visualisation du pdf (et donc sur le fichier pdf généré au final). Le caractère occupe bien sa place mais il est invisible. À l'affichage, le rendu est comme si on avait remplacé le "à" par un \skip.

Dans l'exemple :
\relative c'' { c c c c }
\addlyrics { Il est à toi }

Rien n'apparaît sous la 3e noire et les paroles deviennent "Il est toi".

Le problème est rentré dans l'ordre dès que j'ai réinstallé la version 2.20.
Suis-je le seul à avoir ce problème ?

Bonne soirée à tous

Thierry

Bonjour à tous,

Ayant Windows 7, j'ai eu ce même problème et je l'avais signalé. Cela me
donne en plus une erreur de type Warning et le caractère est remplacé
par une espace.
Je n'ai pas eu la solution à ce problème qui, semble-t-il, ne se produit
qu'avec ce caractère. [...]

En attendant de passer à une version de Windows plus récente (ou mieux,
à un Linux tel qu'un Ubuntu comme le conseille fort justement Jean), il
y a quand même un contournement consistant à utiliser l'autre encodage
du à, sous forme décomposée (UTF-8 : 61 CC 80) au lieu de précomposée
(UTF-8 : C3 A0).

Pour cela, copier-coller celui qui se trouve entre les crochets : [à].

Cordialement,

···

Le 19/04/2022 15:01, Jean-Paul Quelen a écrit :
--
Olivier Miakinen

Un grand merci à tous pour vos réponses.

Bien cordialement

Thierry

Télécharger Outlook pour Android