problème de présentation des partitions dans lilypond

Bonjour,

Ca fait quelques jours que je ne travaille plus avec Lilypond et je viens de me rendre compte que dans la partie droite de Jedit la partition se présente bizarrement !

Je m'explique :

certaines notes son normales et certaines autres sont *sans queue* ! Certaines noires, avec queue et certaines sans, idiem pour les croches.

C'est assez curieux à voir et assez perturbant.

par contre, la sortie PDF est correcte !

Une explication .

Je suis sous Lilypond 2.13.46

Merci de vos réponses

···

--
JJG
(En raison du degré important de mon "oublitude", je demande à mes
correspondants de me prévenir à l'approche d'un rendez-vous prochain)

On en a parlé il y a quelques jours :
http://lists.gnu.org/archive/html/lilypond-user-fr/2011-01/msg00468.html

Bertrand

Merci Bertrand mais quel que soit le programme que je mette pour visionner les partitions (okular, xpdf, evince) le résultat est le même : pas de changement. Par contre, la sortie PDF avec Adobe est parfait !

J'espère que je pourrai voir mes partitions normalement (comme jusqu'à présent) dans Jedit à nouveau.

Merci encore

···

Le 06/02/2011 13:14, Bertrand Bordage a écrit :

On en a parlé il y a quelques jours :
Encore un problème de rendu PDF à l'é cran

Bertrand

--
JJG
(En raison du degré important de mon "oublitude", je demande à mes
correspondants de me prévenir à l'approche d'un rendez-vous prochain)

Salut Jean-Jacques,

Que veux-tu dire par
quel que soit le programme que je mette pour visionner

les partitions (okular, xpdf, evince) ?

Parles-tu toujours du rendu PDF à l'intérieur de jEdit/LilyPondTool ?
Si oui, comment as-tu "mis" les programmes cités ?

Gilles T.

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/probleme-de-presentation-des-partitions-dans-lilypond-tp5996322p5997609.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Mêmes questions que Gilles.

Pour moi le problème est dû à LilyPondTool (comme dans le sujet "Encore
un problème de rendu PDF à l'écran", de Gilles justement).
http://lilypond-french-users.1298960.n2.nabble.com/Encore-un-probleme-de-rendu-PDF-a-l-ecran-td5976907.html

Dans ce cas, quelle version de jEdit, quelle version de LilyPondTool ?
OK, en écrivant ce message je viens de voir que j'avais le problème
aussi ! :smiley:
LilyPondTool version 2.12.894 ; je viens de tester la 2.12.932 et
le problème est toujours présent.

Je n'avais pas remarqué le problème auparavant. J'ai le sentiment qu'il
a dû survenir suite à une mise à jour d'un programme de la distribution
ou d'un plugin jEdit.

On est tous les trois sous GNU/Linux :
Ubuntu 10.10 pour Gilles et moi, Kubuntu 10.4 pour Jean-Jacques, c'est
bien correct ? jEdit 4.3.2 pour tout le monde ?

Cordialement,
Xavier

···

2011/2/6 Gilles Tiar <****@****>:

Salut Jean-Jacques,

Que veux-tu dire par

quel que soit le programme que je mette pour visionner
les partitions (okular, xpdf, evince) ?

Parles-tu toujours du rendu PDF à l'intérieur de jEdit/LilyPondTool ?
Si oui, comment as-tu "mis" les programmes cités ?

--
Xavier Scheuer <****@****>

Salut Jean-Jacques,

Bon
,jour,

Mêmes questions que Gilles.

Pour moi le problème est dû à LilyPondTool (comme dans le sujet "Encore
un problème de rendu PDF à l'écran", de Gilles justement).
http://lilypond-french-users.1298960.n2.nabble.com/Encore-un-probleme-de-rendu-PDF-a-l-ecran-td5976907.html

Dans ce cas, quelle version de jEdit, quelle version de LilyPondTool ?
OK, en écrivant ce message je viens de voir que j'avais le problème
aussi ! :smiley:
LilyPondTool version 2.12.894 ; je viens de tester la 2.12.932 et
le problème est toujours présent.

Je n'avais pas remarqué le problème auparavant. J'ai le sentiment qu'il
a dû survenir suite à une mise à jour d'un programme de la distribution
ou d'un plugin jEdit.

Oui, c'est survenu du jour au lendemain. De mon côté, je n'ai rien fait de spécial et, en ouvrant un fichier, je me suis rendu comptequ'il n'était pas comme avant !

On est tous les trois sous GNU/Linux :
Ubuntu 10.10 pour Gilles et moi, Kubuntu 10.4 pour Jean-Jacques, c'est
bien correct ? jEdit 4.3.2 pour tout le monde ?

Pour moi, je n'ai pas réussi à trouver le N° de version de LilypondTool mais j'ai trouvé dans mon /home/user/LilypondTool/props/Plugin.lilytool.lilyToolPlugin.version= 2.12879.

Je suis en effet sous Kubuntu 10.04.02 LTS
et Jedit 4.3.2.

Il semble donc que nous ayons tous les trois le même problème.

Faudra-t-il qu'on passe sous Windows ? :slight_smile:

PS pas eu le temps encore de mettre les paroles dans mon fichier. Il y a des erreurs de durées et je n'arrive pas à trouver.... grrrrr !)

···

Le 07/02/2011 13:28, Xavier Scheuer a écrit :

2011/2/6 Gilles Tiar<****@****>:

--
JJG
(En raison du degré important de mon "oublitude", je demande à mes
correspondants de me prévenir à l'approche d'un rendez-vous prochain)

Je suis sous :
Ubuntu 10.10,
jEdit 4.3.2,
LilyPondTool 2.12.894, (Jean-Jacques regarde dans jEdit/Plugins/Plugin
Manager, la version de LilyPondTool doit y apparaître, mais je ne suis pas
sûr que le problème vienne de là),
Lilypond 2.13.47 (j'étais sous 2.13.46 quand le problème s'est révélé, je
suis passé à .47, mais cela n'a rien changé).

Je pense que le problème est survenu suite à un élément de mise à niveau qui
a eu lieu aux environs du 27 ou 28 janvier (pour moi). Si quelqu'un se sent
de vérifier lequel, je joins un fichier indiquant les mises à jour ayant eu
lieu ces jours-là :
http://lilypond-french-users.1298960.n2.nabble.com/file/n6000369/mises_a_jour_27_et__28.01.odt
mises_a_jour_27_et__28.01.odt

En attendant, j'utilise Frescobaldi, comme on me l'a suggéré. Le rendu PDF
interne est très bon. En attendant que le problème se règle sous
jEdit/LilyPondTool. Après quoi ce sera une bonne occasion de comparer les
deux.

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/probleme-de-presentation-des-partitions-dans-lilypond-tp5996322p6000369.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Le 07/02/2011 13:50, Jean-Jacques Gerbaud disait :

PS pas eu le temps encore de mettre les paroles dans mon fichier. Il y a
des erreurs de durées et je n'arrive pas à trouver.... grrrrr !)

J'aurais dû en ajouter dans ma bière !
Pensez de temps en temps à inclure des | en fin de mesure, de telle sorte que Lily vous le fasse savoir lorsque ce n'est pas sa place :
« Avertissement : échec du contrôle de mesure (barcheck) à : LÀ »

@+
Jean-Charles

Je vois openjdk et icedtea , c'est-à-dire Java.
jEdit étant écrit en Java, je suppose que c'est cette mise à jour qui
a amené le problème. En fait le problème vient peut-être du paquet
Ubuntu uniquement.

Si je remplace le paquet openjdk-6-jre par sun-java6-jre le problème est
résolu (attention : il faut supprimer openjdk-6-jre).
Vous pouvez me confirmer que c'est pareil chez vous ?

Je viens d'envoyer un mail à Bertalan (et à la liste de diffusion
LilyPondTool) pour signaler ce problème.

Cordialement,
Xavier

···

2011/2/7 Gilles Tiar <****@****>:

Je suis sous :
Ubuntu 10.10,
jEdit 4.3.2,
LilyPondTool 2.12.894, (Jean-Jacques regarde dans jEdit/Plugins/Plugin
Manager, la version de LilyPondTool doit y apparaître, mais je ne suis pas
sûr que le problème vienne de là),
Lilypond 2.13.47 (j'étais sous 2.13.46 quand le problème s'est révélé, je
suis passé à .47, mais cela n'a rien changé).

Je pense que le problème est survenu suite à un élément de mise à niveau qui
a eu lieu aux environs du 27 ou 28 janvier (pour moi). Si quelqu'un se sent
de vérifier lequel, je joins un fichier indiquant les mises à jour ayant eu
lieu ces jours-là :
http://lilypond-french-users.1298960.n2.nabble.com/file/n6000369/mises_a_jour_27_et__28.01.odt
mises_a_jour_27_et__28.01.odt

--
Xavier Scheuer <****@****>

Confirmé !
Attention cependant, en suivant strictement les indications de Xavier, jEdit ne marchait plus.
Il a fallu :

Désinstaller entièrement (fichiers de configuration compris) openjdk6-jre et openjdk6-jre-headless.

Installer sun-java6-jre

D'autres problèmes seront sans doute résolus ainsi, non ? J'avais des bugs incompréhensibles avec swing, j'espère qu'ils ne seront plus !

Bertrand

Bonsoir à tous,

Je suis sous :
Ubuntu 10.10,
jEdit 4.3.2,
LilyPondTool 2.12.894, (Jean-Jacques regarde dans jEdit/Plugins/Plugin
Manager, la version de LilyPondTool doit y apparaître, mais je ne suis pas
sûr que le problème vienne de là)

Je viens de vérifier : 2.12.894 pour moi

···

Le 07/02/2011 21:14, Xavier Scheuer a écrit :

2011/2/7 Gilles Tiar<****@****>:

,

Lilypond 2.13.47 (j'étais sous 2.13.46 quand le problème s'est révélé, je
suis passé à .47, mais cela n'a rien changé).

Je pense que le problème est survenu suite à un élément de mise à niveau qui
a eu lieu aux environs du 27 ou 28 janvier (pour moi). Si quelqu'un se sent
de vérifier lequel, je joins un fichier indiquant les mises à jour ayant eu
lieu ces jours-là :
http://lilypond-french-users.1298960.n2.nabble.com/file/n6000369/mises_a_jour_27_et__28.01.odt
mises_a_jour_27_et__28.01.odt

Je vois openjdk et icedtea , c'est-à-dire Java.
jEdit étant écrit en Java, je suppose que c'est cette mise à jour qui
a amené le problème. En fait le problème vient peut-être du paquet
Ubuntu uniquement.

Si je remplace le paquet openjdk-6-jre par sun-java6-jre le problème est
résolu (attention : il faut supprimer openjdk-6-jre).
Vous pouvez me confirmer que c'est pareil chez vous ?

Pour moi, j'ai d'abord fini le travail important que j'avais à faire avant de faire quelque manip' que ce soit.

Après l'envoi de mon travail à son destinataire, j'ai désinstallé open-6-jre et tous les fichiers qui portaient également un nom approchant (devel, util...) et en voulant installer sun-java6-jre je me suis aperçu qu'il était déjà dans ma config.. J'ai demandé à synaptic une nouvelle réinstallation pour le cas où et ...ta..da...daaaa

Tout baigne, non seulement il n'y a pas d'erreur au lancement de lilypond mais ma partition est toute belle dans la partie droite de Jedit ! Comme avant

Maintenant, je n'ai pas relancé la machine. J'espère que demain je n'aurai pas de désagréable surprise !

Bonne nuit à tous.

--
JJG
(En raison du degré important de mon "oublitude", je demande à mes
correspondants de me prévenir à l'approche d'un rendez-vous prochain)

Salut à tous,

Changement de version java effectué, tout fonctionne comme il faut.

Je pensais aussi que le problème venait de là, j'avais connu un problème
assez proche il y a quelques années que j'avais résolu en remplaçant
"java-6-openjdk/jre/bin/java par : java-1.5.0-sun/jre/bin/java.

Super,

Gilles T.

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/probleme-de-presentation-des-partitions-dans-lilypond-tp5996322p6003181.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.