problème d'installation de LilypondTool

Bonjour à tous,

Je m'efforce d'installer le plugin LilyPondTool comme indiqué dans les tutoriels de valentin Villenave. (mes compliments et félicitations en passant). Quelles que soient les versions de java que j'installe, j'arrive toujours à une somme astronomique d'erreurs à la fin de l'installation du plugin. Voici les dernières que je viens de recevoir !

A beanshell error occurred :
java.lang.NoClassDefFoundError: lilytool/parser/LilySideKickParser$Block
  at java.lang.Class.getDeclaredConstructors0(Native Method)
  at java.lang.Class.privateGetDeclaredConstructors(Class.java:2407)
  at java.lang.Class.getConstructors(Class.java:1477)
  at org.gjt.sp.jedit.bsh.Reflect.constructObject(Reflect.java:603)
  at org.gjt.sp.jedit.bsh.BSHAllocationExpression.constructObject(BSHAllocationExpression.java:123)
  at org.gjt.sp.jedit.bsh.BSHAllocationExpression.objectAllocation(BSHAllocationExpression.java:114)
  at org.gjt.sp.jedit.bsh.BSHAllocationExpression.eval(BSHAllocationExpression.java:62)
  at org.gjt.sp.jedit.bsh.BSHPrimaryExpression.eval(BSHPrimaryExpression.java:102)
  at org.gjt.sp.jedit.bsh.BSHPrimaryExpression.eval(BSHPrimaryExpression.java:47)
  at org.gjt.sp.jedit.bsh.Interpreter.eval(Interpreter.java:644)
  at org.gjt.sp.jedit.bsh.Interpreter.eval(Interpreter.java:738)
  at org.gjt.sp.jedit.bsh.Interpreter.eval(Interpreter.java:727)
  at org.gjt.sp.jedit.BeanShellFacade._eval(BeanShellFacade.java:148)
  at org.gjt.sp.jedit.BeanShellFacade.eval(BeanShellFacade.java:113)
  at org.gjt.sp.jedit.BeanShell.eval(BeanShell.java:369)
  at org.gjt.sp.jedit.ServiceManager$Descriptor.getInstance(ServiceManager.java:295)
  at org.gjt.sp.jedit.ServiceManager.getService(ServiceManager.java:238)
  at sidekick.SideKickPlugin.getParser(SideKickPlugin.java:175)
  at sidekick.SideKickPlugin.getParserForBuffer(SideKickPlugin.java:234)
  at sidekick.SideKick.parse(SideKick.java:161)
  at sidekick.SideKickPlugin.initView(SideKickPlugin.java:292)
  at sidekick.SideKickPlugin.start(SideKickPlugin.java:78)
  at org.gjt.sp.jedit.PluginJAR.startPlugin(PluginJAR.java:1392)
  at org.gjt.sp.jedit.PluginJAR.activatePlugin(PluginJAR.java:753)
  at org.gjt.sp.jedit.PluginJAR.activatePluginIfNecessary(PluginJAR.java:823)
  at org.gjt.sp.jedit.pluginmgr.Roster.performOperationsInAWTThread(Roster.java:137)
  at org.gjt.sp.jedit.pluginmgr.InstallPanel$InstallButton.actionPerformed(InstallPanel.java:925)
  at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2013)
  at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2336)
  at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
  at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:260)
  at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:254)
  at java.awt.Component.processMouseEvent(Component.java:6100)
  at javax.swing.JComponent.processMouseEvent(JComponent.java:3288)
  at java.awt.Component.processEvent(Component.java:5865)
  at java.awt.Container.processEvent(Container.java:2099)
  at java.awt.Component.dispatchEventImpl(Component.java:4461)
  at java.awt.Container.dispatchEventImpl(Container.java:2157)
  at java.awt.Component.dispatchEvent(Component.java:4287)
  at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4455)
  at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4119)
  at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4049)
  at java.awt.Container.dispatchEventImpl(Container.java:2143)
  at java.awt.Window.dispatchEventImpl(Window.java:2555)
  at java.awt.Component.dispatchEvent(Component.java:4287)
  at java.awt.EventQueue.dispatchEvent(EventQueue.java:605)
  at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:276)
  at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:201)
  at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:191)
  at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:186)
  at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
  at java.awt.EventDispatchThread.run(EventDispatchThread.java:139)
Caused by: java.lang.ClassNotFoundException: lilytool.parser.LilySideKickParser$Block
  at java.net.URLClassLoader$1.run(URLClassLoader.java:221)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.net.URLClassLoader.findClass(URLClassLoader.java:209)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:324)
  at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:269)
  at org.gjt.sp.jedit.JARClassLoader.loadFromParent(JARClassLoader.java:510)
  at org.gjt.sp.jedit.JARClassLoader.loadClass(JARClassLoader.java:87)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:269)
  at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:337)
  ... 52 more

ces "52 more" laissent supposer que les erreurs sont encore plus nombreuses mais est ce nécessaires de les savoir toutes après le nombre important de celles qui précèdent ?

Je suis Sous Linux Mandriva 2008.0, KDE, les versions de java installées :
java-1.6.0-sun., jdk-6u17-linux-i586.rpm

Sur le site de java, on propose de vérifier la version installée sur le système et le test s'est avéré conforme ! (au moins ça :slight_smile:

Si quelqu'un peut me donner une piste pour résoudre ce problème. Merci

···

--
Jean-Jacques Gerbaud
Entre Dauphiné et PACA

Pour ma part j'utilise l'openJDK sans aucun problème... serait-ce dû à
cette (ancienne) version de Mandriva ? Sinon, de quelle version de
jEdit s'agit-il ?

Cordialement,
Valentin

···

2009/11/18 Jean-Jacques Gerbaud <****@****>:

Je m'efforce d'installer le plugin LilyPondTool comme indiqué dans les
tutoriels de valentin Villenave. (mes compliments et félicitations en
passant). Quelles que soient les versions de java que j'installe, j'arrive
toujours à une somme astronomique d'erreurs à la fin de l'installation du
plugin. Voici les dernières que je viens de recevoir !

Bonjour,
à la réflexion, je me demande si ce n'est pas un bête problème de
conflit entre d'anciennes versions de certains plugins.

Que se passerait-il si vous renommiez le répertoire .jedit/ dans votre
dossier personnel, et réinstalliez LilyPondTool de zéro via le Plugin
Manager ?

Cordialement,
Valentin

···

2009/11/18 Jean-Jacques Gerbaud <****@****>:

java.lang.NoClassDefFoundError: lilytool/parser/LilySideKickParser$Block