Problème Installation: feta fonts

Bonjour,

Je rame depuis deux jours pour installer Lilypond sur ma Slackware 13.1 (64 bits). Evidemments, je suis obligé de passer par les Slackbuilds. Mais...

-Celui qu'on trouve sur http://pkgs.org/slackware-13.1/slacky-i486/lilypond-2.12.3-i486-1sl.txz.html met en place des exécutables qui sont trouvés mais refusent de s'exécuter (/usr/bin/lilypond: no such files or directory)

-Celui qu'on trouve sur http://slackbuilds.org/repository/13.1/graphics/lilypond/ (Version 2.13.46)) bloque sur des fichiers de fontes qu'il exige, qui ne sont pas fournis avec et qu'on ne trouve nulle part:

Message d'erreur:
cannot open /tmp/SBo/lilypond-2.13.46/mf/out/feta11.pfb
The requested file, feta11.pfb, does not exist
Mergefonts: can't find font: feta11.pfb
Called from
emmentaler-11.pe: line 17

J'ai cherché à me procurer ce fichier feta11.pfb, mais bernique !!! On trouve bien à la rigueur des fichiers rpm pour fedora qui contiennent ce foutues feta fontes, mais je ne peux m'en servir, la commande rpm2tgz échouant systématiquement sur eux. J'ai trouvé des liens sur le site lilypond.org qui indiquent qu'on pouvait jadis y télécharger ces feta fontes, mais ils sont morts. J'ai même trouvé une info prétendant que ces fichiers n'existent plus dans les ver
sions récentes, mais alors pourquoi l'installation en a t'elle besoin ?

Bref, s'il vous plaît, savez vous où je peux me procurer ces feta fontes et en particulier le feta11.pfb qui est nécessaire à l'isntallation et qu'on ne trouve nulle part ???

Merci d'avance !

Pierre-Jean Tuloup

Pour la version 2.12, est-ce que le fichier /usr/bin/lilypond a la permission pour s'exécuter ?
Si tu as un doute, un petit
sudo chmod +x /usr/bin/lilypond
et réessaie.

Pour la version 2.13, je n'ai pas trop le courage de regarder en détail. Je te conseille de compiler la source, à partir du tar du site de lilypond ou du dépôt git.

Cordialement,
Bertrand

Bonjour,

Et merci pour la rapidité de la réponse !

Oui, bien sûr, l'exécutable avait les droits, et ce n'était pas non plus une question de PATH, car je le lançais avec ./ dans le répertoire même. Mais bon j'ai abandonné la version 2.12 devant ces problèmes incomprhéensibles (pour moi en tout cas).

Pour la version 2.13, il ne manque vraiment pas grand chose: pourquoi ces fonts sont-elles impossibles à trouver nulle part, alors que l'install les réclame ? Est-ce que le slackbuild est mal fait ? Quelqu'un ici a t'il déjà installé lilypond à partir du slackbuild de slackbuild.org pour Slackware 13.1 ?

Bon, je vais essayer à partir de la source quand j'aurai un peu le temps...

A plus tard...

···

----- Message d'origine -----

De : Bertrand Bordage

Envoyés : 23.03.11 00:24

À : ****@****

Objet : Re: Problème Installation: feta fonts

Pour la version 2.12, est-ce que le fichier /usr/bin/lilypond a la permission pour s'exécuter ?

Si tu as un doute, un petit
sudo chmod +x /usr/bin/lilypond
et réessaie.

Pour la version 2.13, je n'ai pas trop le courage de regarder en détail. Je te conseille de compiler la source, à partir du tar du site de lilypond ou du dépôt git.

Cordialement,
Bertrand

Bonjour,

Et merci pour la rapidité de la réponse !

Oui, bien sûr, l'exécutable avait les droits, et ce n'était pas non plus une
question de PATH, car je le lançais avec ./ dans le répertoire même. Mais
bon j'ai abandonné la version 2.12 devant ces problèmes incomprhéensibles
(pour moi en tout cas).

Pour la version 2.13, il ne manque vraiment pas grand chose: pourquoi ces
fonts sont-elles impossibles à trouver nulle part, alors que l'install les
réclame ?

Les fontes feta sont les fontes musicales (pour représenter les notes et
autres signes musicaux) de LilyPond.
Donc c'est compréhensible que tu aies du mal à les trouver ailleurs.
Normal aussi que l'install les réclame.

Par contre il devraient être fournis (d'ailleurs ils le sont dans le
premier lien 2.12.3 que tu as donné) !

Est-ce que le slackbuild est mal fait ? Quelqu'un ici a t'il déjà
installé lilypond à partir du slackbuild de slackbuild.org pour Slackware
13.1 ?

Le site LilyPond mentionne cette page pour le package Slackware :
http://www.johannes-schoepfer.de/lilypond/
Il y a la dernière version stable de LilyPond 2.12.3, pour Slackware
13.1 :
http://slackware.schoepfer.info/13.1/slackware/music/lilypond-2.12.3-i686-1jsc.txz

Bon, je vais essayer à partir de la source quand j'aurai un peu le temps...

Sinon il y a aussi les scripts sh pour installer LilyPond sur n'importe
quel GNU/Linux (facile et rapide) :
http://lilypond.org/unix.html

Quitte à installer LilyPond pourquoi ne pas installer la version
2.13.54 de développement ? Comme ça quand la version stable 2.14
sortira d'ici peu tu ne seras pas dépaysé.

Cordialement,
Xavier

···

2011/3/23 <****@****>:

--
Xavier Scheuer <****@****>

Merci, merci, merci pour le lien (http://www.johannes-schoepfer.de/lilypond/) !

En effet, sur celui-ci se trouve enfin un package 64 bits qui fonctionne: visiblement le slackbuild de slackbuild.org était défectueux, ne comprenant pas les fontes; celui de linuxpackages n'était tout simplement pas en 64 bits et la commande linux32 reste sans effet sur lui (comme d'ailleurs sur le package 32 bits du site schoepfer)

Encore merci, je vais pouvoir enfin me consacrer à la musique !

Cordialement,

Pierre-Jean Tuloup.

···

----- Message d'origine -----

De : Xavier Scheuer

Envoyés : 23.03.11 10:40

À : ****@****

Objet : Re: Re : Re: Problème Installation: feta fonts

 
2011/3/23  <\*\*\*\*@\*\*\*\*>: 
> 
> Bonjour, 
> 
> Et merci pour la rapidité de la réponse ! 
> 
> Oui, bien sûr, l'exécutable avait les droits, et ce n'était pas non plus une 
> question de PATH, car je le lançais avec ./ dans le répertoire même.  Mais 
> bon j'ai abandonné la version 2.12 devant ces problèmes incomprhéensibles 
> (pour moi en tout cas). 
> 
> Pour la version 2.13, il ne manque vraiment pas grand chose: pourquoi ces 
> fonts sont-elles impossibles à trouver nulle part, alors que l'install les 
> réclame ? 

Les fontes feta sont les fontes musicales (pour représenter les notes et 
autres signes musicaux) de LilyPond. 
Donc c'est compréhensible que tu aies du mal à les trouver ailleurs. 
Normal aussi que l'install les réclame. 

Par contre il devraient être fournis (d'ailleurs ils le sont dans le 
premier lien 2.12.3 que tu as donné) ! 

> Est-ce que le slackbuild est mal fait ? Quelqu'un ici a t'il déjà 
> installé lilypond à partir du slackbuild de slackbuild.org pour Slackware 
> 13.1 ? 

Le site LilyPond mentionne cette page pour le package Slackware : 
http://www.johannes-schoepfer.de/lilypond/ 
Il y a la dernière version stable de LilyPond 2.12.3, pour Slackware 
13.1 : 
http://slackware.schoepfer.info/13.1/slackware/music/lilypond-2.12.3-i686-1jsc.txz 

> Bon, je vais essayer à partir de la source quand j'aurai un peu le temps... 

Sinon il y a aussi les scripts sh pour installer LilyPond sur n'importe 
quel GNU/Linux (facile et rapide) : 
http://lilypond.org/unix.html 

Quitte à installer LilyPond pourquoi ne pas installer la version 
2.13.54 de développement ?  Comme ça quand la version stable 2.14 
sortira d'ici peu tu ne seras pas dépaysé. 
http://lilypond.org/doc/v2.13/Documentation/web/unix.html 

Cordialement, 
Xavier 

-- 
Xavier Scheuer <\*\*\*\*@\*\*\*\*>