Probleme Instrument et midi

Bonjour,

J'ai un problème avec la correspondance des instruments et le midi
J'ai fait ce simple test
%%%%%%%%%%%%
\version "2.13.51"

musique = {
  a4 b c d e f g
}

accords = \chordmode {
  r2 d:7
}

\score {
  <<
  \new Staff = A {
    \set Staff.midiInstrument = #"flute" \musique
  }
  \new Staff = B {
    \set Staff.midiInstrument = #"acoustic guitar (nylon)" \accords
  }
  >>
  \layout { }
  \midi { }
}
%%%%%%%

Mais la deuxième note de la flûte passe en guitare
Avant ( version 2.13.44 selon mes changement de version } tout fonctionnait
comme je le voulais.

Est-ce un bug ou mon code qui n'est pas correct ?
Ou autre chose ?
j'ai testé différente combinaisons mais sans succès :(.

Merci de vos lumières ***

···

-----
Lily Pond et le Jazz
--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Probleme-Instrument-et-midi-tp6212372p6212372.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Bonjour,

Il y a eu pas mal de travail sur le MIDI dans les toutes dernières
version. Cela me semble fonctionner correctement avec la 2.13.55.

Cordialement,
Xavier

···

2011/3/27 JeanPi <****@****>:

Bonjour,

J'ai un problème avec la correspondance des instruments et le midi
J'ai fait ce simple test

[...]

Mais la deuxième note de la flûte passe en guitare
Avant ( version 2.13.44 selon mes changement de version } tout fonctionnait
comme je le voulais.

Est-ce un bug ou mon code qui n'est pas correct ?
Ou autre chose ?
j'ai testé différente combinaisons mais sans succès :(.

Merci de vos lumières ***

--
Xavier Scheuer <****@****>

re

Effectivement, après installation de la dernière version 2.13.55.1 tout est
OK.

Merci

···

_______________________________________________
liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-user-fr

-----
Lily Pond et le Jazz
--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Probleme-Instrument-et-midi-tp6212372p6212684.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Bonsoir,

Sur une partition de chant et piano, la première Staff a pour midiInstrument
#"choir aahs", et je ne définis rien pour les seconde et troisième Staff,
qui formeront les md et mg du piano.

Jusqu'à la v2.13.27, j'obtenais bien le résultat attendu: toutes les staffs
sans midiInstrument précisé sont jouées au piano.
Ce n'est plus bon en v2.13.53 et v2.13.60: tout est joué en "aahs"...

Est-ce un bug résiduel sur les modifs midi, ou une nouvelle implémentation
de la fonction (no end... untill new specification) ?

Jean-Christophe--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Probleme-Instrument-et-midi-tp6212372p6321931.html

···

Sent from the LilyPond French Users mailing list archive at Nabble.com.

== En réponse au message du 01-05-2011, 21:41:48 ==

Bonsoir,

Sur une partition de chant et piano, la première Staff a pour midiInstrument
#"choir aahs", et je ne définis rien pour les seconde et troisième Staff,
qui formeront les md et mg du piano.

Jusqu'à la v2.13.27, j'obtenais bien le résultat attendu: toutes les staffs
sans midiInstrument précisé sont jouées au piano.
Ce n'est plus bon en v2.13.53 et v2.13.60: tout est joué en "aahs"...

Est-ce un bug résiduel sur les modifs midi, ou une nouvelle implémentation
de la fonction (no end... untill new specification) ?

Ceci n'est qu'une piste de réponse, je n'ai pas vu le fichier midi, mais LilyPond semble "parfois" oublier l'attribution d'un canal midi aux voix. Toutes les voix sont alors reprises sur le même canal et le seul MidiInstrument rencontré est utilisé pour toutes les voix.
Il faudrait vérifier ceci avec un éditeur Midi.
Et vérifier également ce qui se passe si on place explicitement un "Piano" sur les autres voix.

Cordialement,

Jean-François

···

Jean-Christophe--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Probleme-Instrument-et-midi-tp6212372p6321931.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

_______________________________________________
liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user-fr

========================================

Seventies wrote:

Et vérifier également ce qui se passe si on place explicitement un "Piano"
sur les autres voix.

Cela fonctionnera surement, je vous confirmerai cela dès que j'aurai fait ce
petit test...
Ce qui m'embete est que, si ce "bug" perdure, je vais devoir repasser toutes
mes partitions passées ayant + d'une voix (et instr midi différent)...

Bonne après-midi,
Jean-Christophe

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Probleme-Instrument-et-midi-tp6212372p6347635.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

midiInstrument explicitement sur tous les Staff, cela fonctionne.
Par contre si j'omets une des définition (2nde ou 3ème vx), Lily retient
dans tous les cas non pas la dernière définie, mais la toute première...
Bizarre.

Ciao,
Jean-Christophe

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Probleme-Instrument-et-midi-tp6212372p6349404.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.