Utilisateurs de Frescobaldi sous Linux

Une question qui me revient sans cesse à l'esprit: avec Frescobaldi sous
Linux, lorsqu'on veut utiliser la fonction «Lecteur Midi» (petit bouton tout
an bas, à côté de celui de Rumor) on obtient, enfin: J'obtiens toujours le
message suivant: Impossible de charger le module KMid. Veuillez installer
KMid 2.4.0 ou plus récent. Ce paquet a l'air des plus discrets, puisqu'on ne
le trouve qu'après pas mal de recherches et qu'en plus il faille le
compiler. Zéro pointé pour ma pomme, rien n'y a fait. Y a t-il qqun qui a
réussi ce tour de force?

Bernard

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Utilisateurs-de-Frescobaldi-sous-Linux-tp5924725p5924725.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Je n'utilise pas frescobaldi mais musiKa (cherchez pas c'est un truc perso que
je me bricole à mes moments perdus) et de toute façon j'ai aussi un pb avec
kmid, il n'est plus fourni avec la mandriva mais semble l'être avec d'autres
distros. Ce qui me navre fort...

···

Le samedi 15 janvier 2011, bameylan a écrit :

Impossible de charger le module KMid

--
Cordialement, Daniel Cartron
« Au Paradis, on est assis à la droite de Dieu : c'est normal, c'est la place
du mort. »
Pierre Desproges

Non (mais j'ai pas essayé non plus).

Moi je clique sur "Jouer/Afficher" en haut à droite >
"Jouer monfichier.midi". Et il m'ouvre "monfichier.midi" dans mon
lecteur MIDI par défaut. :slight_smile:

Pour choisir un lecteur MIDI en particulier (par exemple timidity) :
"Configuration > Configurer Frescobaldi... > Emplacements >
Lecteur MIDI" et mettre simplement "timidity".

Et je n'utilise pas le petit bouton tout en bas, à côté de celui de
Rumor.

Cordialement,
Xavier

···

2011/1/15 bameylan <****@****>:

Une question qui me revient sans cesse à l'esprit: avec Frescobaldi sous
Linux, lorsqu'on veut utiliser la fonction «Lecteur Midi» (petit bouton tout
an bas, à côté de celui de Rumor) on obtient, enfin: J'obtiens toujours le
message suivant: Impossible de charger le module KMid. Veuillez installer
KMid 2.4.0 ou plus récent. Ce paquet a l'air des plus discrets, puisqu'on ne
le trouve qu'après pas mal de recherches et qu'en plus il faille le
compiler. Zéro pointé pour ma pomme, rien n'y a fait. Y a t-il qqun qui a
réussi ce tour de force?

--
Xavier Scheuer <****@****>

J'ai trouvé un jour un .deb de la version 2.2.2 sur le site de... opensuze (comprenne qui peut)
Je te l'envoie en privé (450Ko)

J'ai trouvé aussi une version 2.2.4 mais il y a des problèmes de bibliothèque.

Une autre solution que la compil est d'utiliser l'outil alien pour transformer des rpm en deb. Existe chez Mandriva

···

Le 15/01/2011 14:57, bameylan a écrit :

Une question qui me revient sans cesse à l'esprit: avec Frescobaldi sous
Linux, lorsqu'on veut utiliser la fonction «Lecteur Midi» (petit bouton tout
an bas, à côté de celui de Rumor) on obtient, enfin: J'obtiens toujours le
message suivant: Impossible de charger le module KMid. Veuillez installer
KMid 2.4.0 ou plus récent. Ce paquet a l'air des plus discrets, puisqu'on ne
le trouve qu'après pas mal de recherches et qu'en plus il faille le
compiler. Zéro pointé pour ma pomme, rien n'y a fait. Y a t-il qqun qui a
réussi ce tour de force?

Bernard

--
Vincent Gay -
« Les civilisations meurent par suicide, non par meurtre. »
(Arnold Joseph Toynbee)

Je voulais dire 2.4

···

Le 15/01/2011 15:18, Vincent Gay a écrit :

J'ai trouvé aussi une version 2.2.4 mais il y a des problèmes de bibliothèque.

--
Vincent Gay -
« Les civilisations meurent par suicide, non par meurtre. »
(Arnold Joseph Toynbee)

Sur archlinux, Kmid est dans les dépots AUR. Maintenant, pour ubuntu et mandriva, il doit bien y avoir un dépot ou un paquet quelque part.

···

Le 15 janvier 2011 15:24, Vincent Gay <****@****> a écrit :

Le 15/01/2011 15:18, Vincent Gay a écrit :

J'ai trouvé aussi une version 2.2.4 mais il y a des problèmes de bibliothèque.

Je voulais dire 2.4

--
Vincent Gay -
« Les civilisations meurent par suicide, non par meurtre. »
(Arnold Joseph Toynbee)


liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-user-fr

Pour les rpm on trouve grace à http://rpm.pbone.net/ (j'ai vu notamment les paquets pour Mandriva)

Par contre pour Debian et dérivés je n'ai pas trouvé

···

Le 15/01/2011 17:28, phijazz a écrit :

Sur archlinux, Kmid est dans les dépots AUR. Maintenant, pour ubuntu et mandriva, il doit bien y avoir un dépot ou un paquet quelque part.

--
Vincent Gay -
« Les civilisations meurent par suicide, non par meurtre. »
(Arnold Joseph Toynbee)

Avec gentoo j'ai trouvé ça:

Homepage: KMid - KDE UserBase Wiki
Description: a MIDI/Karaoke player for KDE
License: GPL-2

Peut-être utile.
Phil.

···

Le 15/01/2011 19:16, Vincent Gay a écrit :

Le 15/01/2011 17:28, phijazz a écrit :

Sur archlinux, Kmid est dans les dépots AUR. Maintenant, pour ubuntu
et mandriva, il doit bien y avoir un dépot ou un paquet quelque part.

Pour les rpm on trouve grace à http://rpm.pbone.net/ (j'ai vu notamment
les paquets pour Mandriva)

Par contre pour Debian et dérivés je n'ai pas trouvé

> Impossible de charger le module KMid
>
Je n'utilise pas frescobaldi mais musiKa (cherchez pas c'est un truc perso que
je me bricole à mes moments perdus) et de toute façon j'ai aussi un pb avec
kmid, il n'est plus fourni avec la mandriva mais semble l'être avec d'autres
distros. Ce qui me navre fort...

Bonsoir,
J'ai trouvé un paquet en deb.

http://packages.ubuntu.com/hardy-backports/i386/kmid/download

···

Le samedi 15 janvier 2011 à 15:08 +0100, Daniel Cartron a écrit :

Le samedi 15 janvier 2011, bameylan a écrit :

_______________________________________________
liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-user-fr

Hardy = 8.04 (Avril 2008) donc KDE3.x

On veut pas paraître bêcheurs mais il nous faudrait la version 2.4 qui date (je crois) d'août 2010

···

Le 15/01/2011 21:41, daniel a écrit :

Bonsoir,
J'ai trouvé un paquet en deb.

Ubuntu – Error

--
Vincent Gay -
« Les civilisations meurent par suicide, non par meurtre. »
(Arnold Joseph Toynbee)

Vincent Gay wrote:

Ubuntu – Error

Hardy = 8.04 (Avril 2008) donc KDE3.x

On veut pas paraître bêcheurs mais il nous faudrait la version 2.4 qui
date (je crois) d'août 2010

Ce qui est bizarre c'est que la version proposée par ce lien est la 3.5...
quid de la 2.4... comprends pas.

Bernard

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Utilisateurs-de-Frescobaldi-sous-Linux-tp5924725p5925577.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

3.5.10 semble être la version de KDE, quant à Kmid il s'agit de la
2.0... (désolé, je n'ai pas trouvé mieux...)

Daniel

···

Le samedi 15 janvier 2011 à 14:32 -0800, bameylan a écrit :

Vincent Gay wrote:
>
>
>>
>> Ubuntu – Error
>>
> Hardy = 8.04 (Avril 2008) donc KDE3.x
>
> On veut pas paraître bêcheurs mais il nous faudrait la version 2.4 qui
> date (je crois) d'août 2010
>
Ce qui est bizarre c'est que la version proposée par ce lien est la 3.5...
quid de la 2.4... comprends pas.

Bernard

Vincent Gay wrote:

Ubuntu – Error

Hardy = 8.04 (Avril 2008) donc KDE3.x

On veut pas paraître bêcheurs mais il nous faudrait la version 2.4 qui
date (je crois) d'août 2010

Ce qui est bizarre c'est que la version proposée par ce lien est la 3.5...
quid de la 2.4... comprends pas.

Bernard

3.5.10 semble être la version de KDE,

Oui, à cette époque kmid était intégré dans kdemultimédia

quant à Kmid il s'agit de la
2.0... (désolé, je n'ai pas trouvé mieux...)

du reste la version actuelle est parfois appelée kmid2
"KMid2 is a rewrite from scratch, with a new architecture and also some new features." (http://kde-apps.org/content/show.php/KMid2?content=116404)

il semble que des paquets soient disponibles pour Opensuze, Arch, Mandriva Fedora (?) Gentoo et Slackware mais je n'en ai pas trouvé pour Debian et dérivé

j'ai converti les rpm de Suze ainsi que ceux de Mandriva avec Alien. Installation apparemment sans problème mais message d'erreur au lancement de kmid dans TangoStudio (dérivé de Ubuntu 10.04) : /usr/lib/libkmidbackend.so.1: undefined symbol: _ZN9QListData11detach_growEPii. Je crois que ça fait la même chose sous Ubuntu 10.10 (mais j'ai la flemme de rebooter pour vérifier)

Reste la compilation : je vous passe les détails et les difficultés, pour finalement arriver exactement au même résultat ( undefined symbol)

Il doit manquer une pièce au puzzle

Reste que le paquet 2.2 que j'utilise fonctionne avec Frescobaldi 1.02 mais selon Bernard (****@****) pas avec Frescobaldi 1.2

···

Le 16/01/2011 00:11, daniel a écrit :

Le samedi 15 janvier 2011 à 14:32 -0800, bameylan a écrit :

--
Vincent Gay -
« Les civilisations meurent par suicide, non par meurtre. »
(Arnold Joseph Toynbee)

kmid2 n'est pas sous forme de paquet sous arch, mais dans les dépôts AUR, qui contiennent des scripts d'installation ou de compilation. Ce dépôt étant accessible par yaourt, le gestionnaire avancé d'archlinux.

Ceci devrait probablement aider à la compilation (dépendances, procédure,…)
http://aur.archlinux.org/packages/kmid2/kmid2/PKGBUILD

ou en svn

http://aur.archlinux.org/packages/kmid-svn/kmid-svn/PKGBUILD

Tu peux aussi te fier aux ebuild sous gentoo.

···

Le 16 janvier 2011 12:13, Vincent Gay <****@****> a écrit :

Le 16/01/2011 00:11, daniel a écrit :

Le samedi 15 janvier 2011 à 14:32 -0800, bameylan a écrit :

Vincent Gay wrote:

http://packages.ubuntu.com/hardy-backports/i386/kmid/download

Hardy = 8.04 (Avril 2008) donc KDE3.x

On veut pas paraître bêcheurs mais il nous faudrait la version 2.4 qui
date (je crois) d'août 2010

Ce qui est bizarre c'est que la version proposée par ce lien est la 3.5...
quid de la 2.4... comprends pas.

Bernard

3.5.10 semble être la version de KDE,

Oui, à cette époque kmid était intégré dans kdemultimédia

quant à Kmid il s'agit de la
2.0... (désolé, je n'ai pas trouvé mieux...)

du reste la version actuelle est parfois appelée kmid2
"KMid2 is a rewrite from scratch, with a new architecture and also some new features." (http://kde-apps.org/content/show.php/KMid2?content=116404)

il semble que des paquets soient disponibles pour Opensuze, Arch, Mandriva Fedora (?) Gentoo et Slackware mais je n'en ai pas trouvé pour Debian et dérivé

j'ai converti les rpm de Suze ainsi que ceux de Mandriva avec Alien. Installation apparemment sans problème mais message d'erreur au lancement de kmid dans TangoStudio (dérivé de Ubuntu 10.04) : /usr/lib/libkmidbackend.so.1: undefined symbol: _ZN9QListData11detach_growEPii. Je crois que ça fait la même chose sous Ubuntu 10.10 (mais j'ai la flemme de rebooter pour vérifier)

Reste la compilation : je vous passe les détails et les difficultés, pour finalement arriver exactement au même résultat ( undefined symbol)

Il doit manquer une pièce au puzzle

Reste que le paquet 2.2 que j'utilise fonctionne avec Frescobaldi 1.02 mais selon Bernard (****@****) pas avec Frescobaldi 1.2

--
Vincent Gay -
« Les civilisations meurent par suicide, non par meurtre. »
(Arnold Joseph Toynbee)


liste de diffusion lilypond-user-fr
lilypond-user-fr@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-user-fr

Bonjour à tous,

Je suis sous kubuntu lucid, une recherche dans les paquets disponibles a retourné ceci :
kmidimon
KMidimon can monitor a MIDI data stream, in order to diagnose a malfunctioning piece of equipment or to examine the contents of a MIDI sequence during playback. Il semble donc capable de lire un fichier midi, puisqu'il diagnostique ?
Je ne l'ai pas installé car j'ai configuré Fresco pour utiliser timidity, comme présenté il y a peu.

Bon courage,

Pierre-Emmanuel