Frescobaldi et midi sous debian

Bonjour,

J'ai perdu le lien vers la page internet qui m'expliquait les réglages pour écouter directement les midi dans frescobaldi

Je suis sous debian et pulseaudio.
Quand j'essaye d'écouter mes partitions dans frescobaldi, le curseur se déplace dans le lecteur, mais je n'ai pas de son (aucun problème avec audacity ou timidity)

Est-ce que quelqu'un aurait un lien ou une démarche à suivre ?

Raphaël

1 « J'aime »

Bonjour,

Dans frescobaldi 3.2

Menu Edition, Préférences, Réglages Midi choisir le port (chez moi avec FluideSynth ça change à chaque login).

Décocher Fermer les sorties Midi non utilisées sinon le port se ferme au bout 1'une minute .

···

Le mer. 1 mars 2023 à 08:35, <****@****> a écrit :

Bonjour,

J'ai perdu le lien vers la page internet qui m'expliquait les réglages pour écouter directement les midi dans frescobaldi

Je suis sous debian et pulseaudio.
Quand j'essaye d'écouter mes partitions dans frescobaldi, le curseur se déplace dans le lecteur, mais je n'ai pas de son (aucun problème avec audacity ou timidity)

Est-ce que quelqu'un aurait un lien ou une démarche à suivre ?

Raphaël

--

Martial Rameaux

1 « J'aime »

Merci pour ta réponse rapide !

j'ai frescobaldi 3.0 (il me semble qu'une nouvelle version va bientôt sortir en français, j'attends qu'elle sorte pour changer)

-> En réglage midi je n'ai qu'un seul choix "midi through port-0"

-> La case "Fermer les sorties midi non utilisées" est déjà décochée

···

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 01/03/2023 09:01:07 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour,

Dans frescobaldi 3.2

Menu Edition, Préférences, Réglages Midi choisir le port (chez moi avec FluideSynth ça change à chaque login).

Décocher Fermer les sorties Midi non utilisées sinon le port se ferme au bout 1'une minute .

Le mer. 1 mars 2023 à 08:35, <****@****> a écrit :

Bonjour,

J'ai perdu le lien vers la page internet qui m'expliquait les réglages pour écouter directement les midi dans frescobaldi

Je suis sous debian et pulseaudio.
Quand j'essaye d'écouter mes partitions dans frescobaldi, le curseur se déplace dans le lecteur, mais je n'ai pas de son (aucun problème avec audacity ou timidity)

Est-ce que quelqu'un aurait un lien ou une démarche à suivre ?

Raphaël

--

Martial Rameaux

Si cela ne fonctionne pas :

Mettre Timidity en serveur/synthétiseur

Dans Session et démarage

Démarage automatique d'application

Ajouter

Nom : Timidity
Description : lanceur serveur Timidity
Commande : timidity -iA -B2,8 -Os -EFreverb=0&

avec :
timidity - le programme
-iA = mode serveur ALSA client."
-B2,8 = buffer (on peut utiliser "-B4,8", cela donne de meilleurs résultats)
-Os = "Output to alsa" ou - Oj pour Jack
-EFreverb=0& "mode" + "Effect" + "Disable MIDI reverb effect control"

···

Martial Rameaux

1 mars 2023 09:15:50 ****@****:

j'ai frescobaldi 3.0

La version stable de Frescobaldi est actuellement la 3.2

Si j'en crois cette page https://packages.debian.org/search?keywords=frescobaldi même avec bullseye tu devrais être en 3.1.3

Je viens de changer d'ordinateur, et de version de Linux.
J'ai abandonné Timitidy qui grésille beaucoup dans Frescobaldi,

je suis passé à FluideSynth qui fonction très bien aussi.

Cordialement

···

Martial Rameaux

Une discussion récente à ce sujet :

https://github.com/frescobaldi/frescobaldi/issues/1537

Cordialement,

Jean

···

Le mercredi 01 mars 2023 à 08:35 +0100, ****@**** a écrit :

Bonjour,

J'ai perdu le lien vers la page internet qui m'expliquait les réglages pour écouter directement les midi dans frescobaldi

Je suis sous debian et pulseaudio.
Quand j'essaye d'écouter mes partitions dans frescobaldi, le curseur se déplace dans le lecteur, mais je n'ai pas de son (aucun problème avec audacity ou timidity)

Est-ce que quelqu'un aurait un lien ou une démarche à suivre ?

Pour info
Utilisation de soundfont sf2 pour améliorer le rendu sonore
merlin_vienna.sf2 100mo
https://www.davince.tengudev.com/music/others/converted-midi/soundfonts/

···

Martial Rameaux

Bonjour,

ça marche très bien avec ce tutoriel (que je garde précieusement), merci !!

Je n'ai pas testé, mais faudra-t-il à chaque fois que le je lance Qsynth avant Frescobaldi ?

···

De : Jean Abou Samra <****@****>
À : ****@****;
lilypond-user-fr@gnu.org
Sujet : Re: Frescobaldi et midi sous debian
Date : 01/03/2023 10:23:36 Europe/Paris

Le mercredi 01 mars 2023 à 08:35 +0100, ****@**** a écrit :

Bonjour,

J'ai perdu le lien vers la page internet qui m'expliquait les réglages pour écouter directement les midi dans frescobaldi

Je suis sous debian et pulseaudio.
Quand j'essaye d'écouter mes partitions dans frescobaldi, le curseur se déplace dans le lecteur, mais je n'ai pas de son (aucun problème avec audacity ou timidity)

Est-ce que quelqu'un aurait un lien ou une démarche à suivre ?

Une discussion récente à ce sujet :

https://github.com/frescobaldi/frescobaldi/issues/1537

Cordialement,

Jean

Bonjour,

chez moi FluideSynth (Qsynth est une interface graphique en Qt pour fluidsynth) démarre au lancement de xubuntu.

En lançant cette commande dans un terminal : systemctl status >status.txt

je trouve ces lignes
****@****
├─app.slice
│ ├─dconf.service
│ │ └─3853 /usr/libexec/dconf-service
│ ├─fluidsynth.service
│ │ └─859 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r 48000 /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2

···

Martial Rameaux

Merci de ton aide également !

On touche du doigt mes limites en informatique ^^'

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien, je retombe sur user:~$
je verrai bien au prochain démarrage, mais au moins je suis content d'avoir une solution qui fonctionne !

···

Martial Rameaux

2 mars 2023 12:06:35 ****@****:

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien

Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

Effectivement un fichier status.txt s'est créé !

Pour moi, ce genre de commande s'apparente à de la magie...

C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?

···

De : Vincent Gay <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 02/03/2023 13:53:40 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

2 mars 2023 12:06:35 ****@****:

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien

Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

Bonjour à tous

Y pas plus simple
c'est un fichier texte
L'ouvrir avec un éditeur de texte "mousepad, leafpad, gedit, writter
de libreoffice... etc."
faire une recherche
menu Edition ou Rechercher ou "ctr+F"
écrire fluid dans la lucarne de recherche
et vous verrez afficher si fluidsynth est démarré
ce genre de ligne :
├─fluidsynth.service
           │ │ └─860 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r
48000 -R on -g 2
/home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2

" /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2" = endroit ou
j'ai mis ma soundfont

Cordialement

···

Le ven. 3 mars 2023 à 09:08, <****@****> a écrit :

Effectivement un fichier status.txt s'est créé !
Pour moi, ce genre de commande s'apparente à de la magie...

C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?

De : Vincent Gay <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 02/03/2023 13:53:40 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

2 mars 2023 12:06:35 ****@****:

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien

Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

--
Martial Rameaux

Bonjour,

Je n'ai pas de fluidsynth dans le fichier status.txt

Je suis sous LXQt, j'ai trouvé les paramétrages de session et le les applications qui se lancent automatiquement au démarrage.

Si je comprends bien, il faudrait que j'ajoute fluidsynth aux applications qui se lancent au démarrage ?
J'ai un bouton "ajouter", on me demande un nom (fluidsynth) et une commande : sur cette dernière je ne sais pas quoi mettre : est-ce fluidsynth également ?

Merci de votre aide à tous, malheureusement mes connaissances en informatiques sont en pointillés (autodidacte)
Raphaël

···

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 03/03/2023 10:48:51 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour à tous

Y pas plus simple
c'est un fichier texte
L'ouvrir avec un éditeur de texte "mousepad, leafpad, gedit, writter
de libreoffice... etc."
faire une recherche
menu Edition ou Rechercher ou "ctr+F"
écrire fluid dans la lucarne de recherche
et vous verrez afficher si fluidsynth est démarré
ce genre de ligne :
├─fluidsynth.service
│ │ └─860 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r
48000 -R on -g 2
/home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2

" /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2" = endroit ou
j'ai mis ma soundfont

Cordialement

Le ven. 3 mars 2023 à 09:08, <****@****> a écrit :

Effectivement un fichier status.txt s'est créé !
Pour moi, ce genre de commande s'apparente à de la magie...

C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?

De : Vincent Gay <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 02/03/2023 13:53:40 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

2 mars 2023 12:06:35 ****@****:

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien

Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

--
Martial Rameaux

Bonjour

Je crois que moi ça s'est installer en proces.service quand j'ai
installé TuxGuitar ou Musescore

Cependant pour le démarrage automatique
on ajoute
Nom : FluidSynth
Description : démarage synthé
Commande : fluidsynth -a pulseaudio -m alsa_seq -i -l -s -p
FluidSynth /usr/share/soundfonts/default.sf2
declencher : on login

et adapter l'endroit où se trouve le dossier et la soundfont utilisé
FluidSynth /usr/share/soundfonts/default.sf2

si cela ne fonctionne pas faudra passer par "fluidsynth.service"
mais je n'ai pas encore testé en partant de zéro.

Cordialement

···

Le dim. 5 mars 2023 à 08:35, <****@****> a écrit :

Bonjour,

Je n'ai pas de fluidsynth dans le fichier status.txt

Je suis sous LXQt, j'ai trouvé les paramétrages de session et le les applications qui se lancent automatiquement au démarrage.

Si je comprends bien, il faudrait que j'ajoute fluidsynth aux applications qui se lancent au démarrage ?
J'ai un bouton "ajouter", on me demande un nom (fluidsynth) et une commande : sur cette dernière je ne sais pas quoi mettre : est-ce fluidsynth également ?

Merci de votre aide à tous, malheureusement mes connaissances en informatiques sont en pointillés (autodidacte)
Raphaël

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 03/03/2023 10:48:51 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour à tous

Y pas plus simple
c'est un fichier texte
L'ouvrir avec un éditeur de texte "mousepad, leafpad, gedit, writter
de libreoffice... etc."
faire une recherche
menu Edition ou Rechercher ou "ctr+F"
écrire fluid dans la lucarne de recherche
et vous verrez afficher si fluidsynth est démarré
ce genre de ligne :
├─fluidsynth.service
│ │ └─860 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r
48000 -R on -g 2
/home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2

" /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2" = endroit ou
j'ai mis ma soundfont

Cordialement

Le ven. 3 mars 2023 à 09:08, <****@****> a écrit :
>
> Effectivement un fichier status.txt s'est créé !
> Pour moi, ce genre de commande s'apparente à de la magie...
>
> C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?
>
>
> De : Vincent Gay <****@****>
> À : ****@****
> Sujet : Re: Frescobaldi et midi sous debian
> Date : 02/03/2023 13:53:40 Europe/Paris
> Copie à : lilypond-user-fr@gnu.org
>
>
> 2 mars 2023 12:06:35 ****@****:
>
> si je tape systemctl status >status.txt dans un terminal, il ne se passe rien
>
> Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

--
Martial Rameaux

--
Martial Rameaux

J'ai réussi à créer le lanceur, et maintenant il apparaît dans le status (voir pièce jointe)

je n'avais que 2 cases : nom et commande
(et chez moi c'est sounds à la place de soundfonts)

Mais ça ne change rien :

  • si je lance frescobaldi, je n'ai pas de son (mais dans les choix de sortie midi j'ai maintenant un choix fluidsynth que je n'avais pas avant)

pour avoir du son, il faut toujours :

  1. que je lance Qsynth
  2. que je lance frescobaldi
  3. dans les préférences midi, il faut que je sélectionne comme sortie midi "Synth input port (3118:0)", qui n’apparaît pas dans les choix si Qsynth n'est pas lancé

Déjà, je suis bien content d'avoir du son
Si tu as une idée pour automatiser un peu tout ça, ça m'intéresse, du moment que ce n'est pas trop chronophage pour toi

fluid.png

···

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 05/03/2023 09:08:53 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour

Je crois que moi ça s'est installer en proces.service quand j'ai
installé TuxGuitar ou Musescore

Cependant pour le démarrage automatique
on ajoute
Nom : FluidSynth
Description : démarage synthé
Commande : fluidsynth -a pulseaudio -m alsa_seq -i -l -s -p
FluidSynth /usr/share/soundfonts/default.sf2
declencher : on login

et adapter l'endroit où se trouve le dossier et la soundfont utilisé
FluidSynth /usr/share/soundfonts/default.sf2

si cela ne fonctionne pas faudra passer par "fluidsynth.service"
mais je n'ai pas encore testé en partant de zéro.

Cordialement

Le dim. 5 mars 2023 à 08:35, <****@****> a écrit :

Bonjour,

Je n'ai pas de fluidsynth dans le fichier status.txt

Je suis sous LXQt, j'ai trouvé les paramétrages de session et le les applications qui se lancent automatiquement au démarrage.

Si je comprends bien, il faudrait que j'ajoute fluidsynth aux applications qui se lancent au démarrage ?
J'ai un bouton "ajouter", on me demande un nom (fluidsynth) et une commande : sur cette dernière je ne sais pas quoi mettre : est-ce fluidsynth également ?

Merci de votre aide à tous, malheureusement mes connaissances en informatiques sont en pointillés (autodidacte)
Raphaël

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 03/03/2023 10:48:51 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour à tous

Y pas plus simple
c'est un fichier texte
L'ouvrir avec un éditeur de texte "mousepad, leafpad, gedit, writter
de libreoffice... etc."
faire une recherche
menu Edition ou Rechercher ou "ctr+F"
écrire fluid dans la lucarne de recherche
et vous verrez afficher si fluidsynth est démarré
ce genre de ligne :
├─fluidsynth.service
│ │ └─860 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r
48000 -R on -g 2
/home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2

" /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2" = endroit ou
j'ai mis ma soundfont

Cordialement

Le ven. 3 mars 2023 à 09:08, <****@****> a écrit :

Effectivement un fichier status.txt s'est créé !
Pour moi, ce genre de commande s'apparente à de la magie...

C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?

De : Vincent Gay <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 02/03/2023 13:53:40 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

2 mars 2023 12:06:35 ****@****:

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien

Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

--
Martial Rameaux

--
Martial Rameaux

si tu as suivit pour la configuration de Qsynth tu as dan s Midi
https://github.com/frescobaldi/frescobaldi/issues/1537

A chaque démarrage il faut aller dans les préférences midi de
Frescobaldi et lui attribuer la sortie midi
exemple à cette heure chez moi = Sortie du lecteur : Synth input port (884:0)
car un nouveau n° de processus (pid) changeant à chaque démarrage de Linux.

dans ton fichier joint il y a écrit déclencher je suis étonné (je suis
sous xfce)
tu n'as pas écris ça dans la commande ?

···

Le dim. 5 mars 2023 à 09:52, <****@****> a écrit :

J'ai réussi à créer le lanceur, et maintenant il apparaît dans le status (voir pièce jointe)
je n'avais que 2 cases : nom et commande
(et chez moi c'est sounds à la place de soundfonts)

Mais ça ne change rien :
- si je lance frescobaldi, je n'ai pas de son (mais dans les choix de sortie midi j'ai maintenant un choix fluidsynth que je n'avais pas avant)

pour avoir du son, il faut toujours :
1. que je lance Qsynth
2. que je lance frescobaldi
3. dans les préférences midi, il faut que je sélectionne comme sortie midi "Synth input port (3118:0)", qui n’apparaît pas dans les choix si Qsynth n'est pas lancé

Déjà, je suis bien content d'avoir du son
Si tu as une idée pour automatiser un peu tout ça, ça m'intéresse, du moment que ce n'est pas trop chronophage pour toi

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 05/03/2023 09:08:53 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour

Je crois que moi ça s'est installer en proces.service quand j'ai
installé TuxGuitar ou Musescore

Cependant pour le démarrage automatique
on ajoute
Nom : FluidSynth
Description : démarage synthé
Commande : fluidsynth -a pulseaudio -m alsa_seq -i -l -s -p
FluidSynth /usr/share/soundfonts/default.sf2
declencher : on login

et adapter l'endroit où se trouve le dossier et la soundfont utilisé
FluidSynth /usr/share/soundfonts/default.sf2

si cela ne fonctionne pas faudra passer par "fluidsynth.service"
mais je n'ai pas encore testé en partant de zéro.

Cordialement

Le dim. 5 mars 2023 à 08:35, <****@****> a écrit :
>
> Bonjour,
>
> Je n'ai pas de fluidsynth dans le fichier status.txt
>
> Je suis sous LXQt, j'ai trouvé les paramétrages de session et le les applications qui se lancent automatiquement au démarrage.
>
> Si je comprends bien, il faudrait que j'ajoute fluidsynth aux applications qui se lancent au démarrage ?
> J'ai un bouton "ajouter", on me demande un nom (fluidsynth) et une commande : sur cette dernière je ne sais pas quoi mettre : est-ce fluidsynth également ?
>
> Merci de votre aide à tous, malheureusement mes connaissances en informatiques sont en pointillés (autodidacte)
> Raphaël
>
>
> De : Martial R <****@****>
> À : ****@****
> Sujet : Re: Frescobaldi et midi sous debian
> Date : 03/03/2023 10:48:51 Europe/Paris
> Copie à : lilypond-user-fr@gnu.org
>
> Bonjour à tous
>
> Y pas plus simple
> c'est un fichier texte
> L'ouvrir avec un éditeur de texte "mousepad, leafpad, gedit, writter
> de libreoffice... etc."
> faire une recherche
> menu Edition ou Rechercher ou "ctr+F"
> écrire fluid dans la lucarne de recherche
> et vous verrez afficher si fluidsynth est démarré
> ce genre de ligne :
> ├─fluidsynth.service
> │ │ └─860 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r
> 48000 -R on -g 2
> /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2
>
> " /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2" = endroit ou
> j'ai mis ma soundfont
>
> Cordialement
>
>
> Le ven. 3 mars 2023 à 09:08, <****@****> a écrit :
> >
> > Effectivement un fichier status.txt s'est créé !
> > Pour moi, ce genre de commande s'apparente à de la magie...
> >
> > C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?
> >
> >
> > De : Vincent Gay <****@****>
> > À : ****@****
> > Sujet : Re: Frescobaldi et midi sous debian
> > Date : 02/03/2023 13:53:40 Europe/Paris
> > Copie à : lilypond-user-fr@gnu.org
> >
> >
> > 2 mars 2023 12:06:35 ****@****:
> >
> > si je tape systemctl status >status.txt dans un terminal, il ne se passe rien
> >
> > Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier
>
>
>
> --
> Martial Rameaux

--
Martial Rameaux

--
Martial Rameaux

Voici la procédure sous débian pour avoir FluidSynth en démarrage automatique

https://wiki.debian.org/PulseAudioMidi

  1. installer Fluidsynth, sudo apt-get install fluidsynth, ça c'est fait
  2. Ouvrez ensuite /etc/default/fluidsynth avec votre éditeur préféré (leafpad, mouspad.. etc.)
    sudo Monéditeur /etc/default/fluidsynth

définissez les paramètres (
lécrire ces lignes si elles n'existe pas ) :

SOUND_FONT=/cheminDeMaSoundfont/sound.sf2
OTHER_OPTS='-a pulseaudio -m alsa_seq -g 1 -o midi.autoconnect=1 -r 48000'

  1. Démarrage et démarrage automatique de FluidSynth
    taper dans un terminal
    systemctl --user start fluidsynth.service

Pour un Démarrage automatique de FluidSynth lors de la connexion de l'utilisateur,
vous devez d'abord modifier le fichier /usr/lib/systemd/user/fluidsynth.service ,
remplacer l'option WantedBy par la valeur default.target comme ceci :
[Install]
WantedBy=default.target

Et puis activez le démarrage automatique à partir de la ligne de commande (dans un terminal) :

systemctl enable --user fluidsynth.service

Redémarrer
ça devrait fonctionner

Cordialement

···

Le dim. 5 mars 2023 à 10:07, Martial R <****@****> a écrit :

si tu as suivit pour la configuration de Qsynth tu as dan s Midi
https://github.com/frescobaldi/frescobaldi/issues/1537

A chaque démarrage il faut aller dans les préférences midi de
Frescobaldi et lui attribuer la sortie midi
exemple à cette heure chez moi = Sortie du lecteur : Synth input port (884:0)
car un nouveau n° de processus (pid) changeant à chaque démarrage de Linux.

dans ton fichier joint il y a écrit déclencher je suis étonné (je suis
sous xfce)
tu n'as pas écris ça dans la commande ?

Le dim. 5 mars 2023 à 09:52, <****@****> a écrit :

J'ai réussi à créer le lanceur, et maintenant il apparaît dans le status (voir pièce jointe)
je n'avais que 2 cases : nom et commande
(et chez moi c'est sounds à la place de soundfonts)

Mais ça ne change rien :

  • si je lance frescobaldi, je n'ai pas de son (mais dans les choix de sortie midi j'ai maintenant un choix fluidsynth que je n'avais pas avant)

pour avoir du son, il faut toujours :

  1. que je lance Qsynth
  2. que je lance frescobaldi
  3. dans les préférences midi, il faut que je sélectionne comme sortie midi "Synth input port (3118:0)", qui n’apparaît pas dans les choix si Qsynth n'est pas lancé

Déjà, je suis bien content d'avoir du son
Si tu as une idée pour automatiser un peu tout ça, ça m'intéresse, du moment que ce n'est pas trop chronophage pour toi

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 05/03/2023 09:08:53 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour

Je crois que moi ça s'est installer en proces.service quand j'ai
installé TuxGuitar ou Musescore

Cependant pour le démarrage automatique
on ajoute
Nom : FluidSynth
Description : démarage synthé
Commande : fluidsynth -a pulseaudio -m alsa_seq -i -l -s -p
FluidSynth /usr/share/soundfonts/default.sf2
declencher : on login

et adapter l'endroit où se trouve le dossier et la soundfont utilisé
FluidSynth /usr/share/soundfonts/default.sf2

si cela ne fonctionne pas faudra passer par "fluidsynth.service"
mais je n'ai pas encore testé en partant de zéro.

Cordialement

Le dim. 5 mars 2023 à 08:35, <****@****> a écrit :

Bonjour,

Je n'ai pas de fluidsynth dans le fichier status.txt

Je suis sous LXQt, j'ai trouvé les paramétrages de session et le les applications qui se lancent automatiquement au démarrage.

Si je comprends bien, il faudrait que j'ajoute fluidsynth aux applications qui se lancent au démarrage ?
J'ai un bouton "ajouter", on me demande un nom (fluidsynth) et une commande : sur cette dernière je ne sais pas quoi mettre : est-ce fluidsynth également ?

Merci de votre aide à tous, malheureusement mes connaissances en informatiques sont en pointillés (autodidacte)
Raphaël

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 03/03/2023 10:48:51 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour à tous

Y pas plus simple
c'est un fichier texte
L'ouvrir avec un éditeur de texte "mousepad, leafpad, gedit, writter
de libreoffice... etc."
faire une recherche
menu Edition ou Rechercher ou "ctr+F"
écrire fluid dans la lucarne de recherche
et vous verrez afficher si fluidsynth est démarré
ce genre de ligne :
├─fluidsynth.service
│ │ └─860 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r
48000 -R on -g 2
/home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2

" /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2" = endroit ou
j'ai mis ma soundfont

Cordialement

Le ven. 3 mars 2023 à 09:08, <****@****> a écrit :

Effectivement un fichier status.txt s'est créé !
Pour moi, ce genre de commande s'apparente à de la magie...

C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?

De : Vincent Gay <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 02/03/2023 13:53:40 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

2 mars 2023 12:06:35 ****@****:

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien

Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

--
Martial Rameaux

--
Martial Rameaux

--
Martial Rameaux

--

Martial Rameaux

ahahah j'en ris tout seul !

Au 1er essai, j'avais copié toute la commande, mais comme il y avait un retour à la ligne (dans le mail) en plein milieu, je n'ai vraiment copié que "fluidsynth -a pulseaudio -m alsa_seq -i -l -s -p" et ça ne fonctionnait pas

donc j'ai supprimé les retours à la ligne et j'ai copié-collé l'expression entière : Commande : "fluidsynth -a pulseaudio -m alsa_seq -i -l -s -p FluidSynth /usr/share/soundfonts/default.sf2 declencher : on login"

je n'avais pas compris que "déclencher" c'était une rubrique !!!

Dans LXQt, il n'y a que "nom" et "commande", et j'ai cru que "declencher : on login" faisait partie de la commande !!
D'où la présence "declencher : on login" dans le status.txt ^^'

Je vais tester la procédure de ton dernier mail !

···

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 05/03/2023 10:07:06 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

si tu as suivit pour la configuration de Qsynth tu as dan s Midi
https://github.com/frescobaldi/frescobaldi/issues/1537

A chaque démarrage il faut aller dans les préférences midi de
Frescobaldi et lui attribuer la sortie midi
exemple à cette heure chez moi = Sortie du lecteur : Synth input port (884:0)
car un nouveau n° de processus (pid) changeant à chaque démarrage de Linux.

dans ton fichier joint il y a écrit déclencher je suis étonné (je suis
sous xfce)
tu n'as pas écris ça dans la commande ?

Le dim. 5 mars 2023 à 09:52, <****@****> a écrit :

J'ai réussi à créer le lanceur, et maintenant il apparaît dans le status (voir pièce jointe)
je n'avais que 2 cases : nom et commande
(et chez moi c'est sounds à la place de soundfonts)

Mais ça ne change rien :

  • si je lance frescobaldi, je n'ai pas de son (mais dans les choix de sortie midi j'ai maintenant un choix fluidsynth que je n'avais pas avant)

pour avoir du son, il faut toujours :

  1. que je lance Qsynth
  2. que je lance frescobaldi
  3. dans les préférences midi, il faut que je sélectionne comme sortie midi "Synth input port (3118:0)", qui n’apparaît pas dans les choix si Qsynth n'est pas lancé

Déjà, je suis bien content d'avoir du son
Si tu as une idée pour automatiser un peu tout ça, ça m'intéresse, du moment que ce n'est pas trop chronophage pour toi

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 05/03/2023 09:08:53 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour

Je crois que moi ça s'est installer en proces.service quand j'ai
installé TuxGuitar ou Musescore

Cependant pour le démarrage automatique
on ajoute
Nom : FluidSynth
Description : démarage synthé
Commande : fluidsynth -a pulseaudio -m alsa_seq -i -l -s -p
FluidSynth /usr/share/soundfonts/default.sf2
declencher : on login

et adapter l'endroit où se trouve le dossier et la soundfont utilisé
FluidSynth /usr/share/soundfonts/default.sf2

si cela ne fonctionne pas faudra passer par "fluidsynth.service"
mais je n'ai pas encore testé en partant de zéro.

Cordialement

Le dim. 5 mars 2023 à 08:35, <****@****> a écrit :

Bonjour,

Je n'ai pas de fluidsynth dans le fichier status.txt

Je suis sous LXQt, j'ai trouvé les paramétrages de session et le les applications qui se lancent automatiquement au démarrage.

Si je comprends bien, il faudrait que j'ajoute fluidsynth aux applications qui se lancent au démarrage ?
J'ai un bouton "ajouter", on me demande un nom (fluidsynth) et une commande : sur cette dernière je ne sais pas quoi mettre : est-ce fluidsynth également ?

Merci de votre aide à tous, malheureusement mes connaissances en informatiques sont en pointillés (autodidacte)
Raphaël

De : Martial R <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 03/03/2023 10:48:51 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

Bonjour à tous

Y pas plus simple
c'est un fichier texte
L'ouvrir avec un éditeur de texte "mousepad, leafpad, gedit, writter
de libreoffice... etc."
faire une recherche
menu Edition ou Rechercher ou "ctr+F"
écrire fluid dans la lucarne de recherche
et vous verrez afficher si fluidsynth est démarré
ce genre de ligne :
├─fluidsynth.service
│ │ └─860 /usr/bin/fluidsynth -is -a alsa -m alsa_seq -r
48000 -R on -g 2
/home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2

" /home/martial/LILYPOND/soundfont/sf2/merlin_vienna.sf2" = endroit ou
j'ai mis ma soundfont

Cordialement

Le ven. 3 mars 2023 à 09:08, <****@****> a écrit :

Effectivement un fichier status.txt s'est créé !
Pour moi, ce genre de commande s'apparente à de la magie...

C'est un peu compliqué pour moi à lire, est-ce que je peux le poster sur la liste pour vous le montrer ?

De : Vincent Gay <****@****>
À : ****@****
Sujet : Re: Frescobaldi et midi sous debian
Date : 02/03/2023 13:53:40 Europe/Paris
Copie à : lilypond-user-fr@gnu.org

2 mars 2023 12:06:35 ****@****:

si je tape systemctl status >status.txt dans un terminal, il ne se passe rien

Je pense que si : tu dois avoir un fichier status txt dans ton répertoire courant. Le signe > indique que tu redirige la sortie standard (l'écran) vers un fichier

--
Martial Rameaux

--
Martial Rameaux

--
Martial Rameaux