lilypond-book-preamble.ly avec version "2.23.9"

Bonjour !
Je n'arrive plus à faire fonctionner lilypond-book-preamble.ly avec la version "2.23.9"...
J'ai essayé avec convert-ly mais rien y fait non plus!

%\version "2.22.2"
\version "2.23.9"

\include "lilypond-book-preamble.ly"
%#(ly:set-option 'aux-files #f)

\score {
\new Staff { c1 }
}

Oui, c'est un truc qui traîne…

https://gitlab.com/lilypond/lilypond/-/issues/6235

Il faut rajouter

#(ly:set-option 'tall-page-formats 'eps,png,pdf)
#(ly:set-option 'separate-page-formats 'eps,png,pdf)

Cordialement,
Jean

···

Le 09/06/2022 à 13:37, Ya Gloops a écrit :

Bonjour !
Je n'arrive plus à faire fonctionner lilypond-book-preamble.ly avec la version "2.23.9"...
J'ai essayé avec convert-ly mais rien y fait non plus!

%\version "2.22.2"
\version "2.23.9"

\include "lilypond-book-preamble.ly"
%#(ly:set-option 'aux-files #f)

\score {
\new Staff { c1 }
}

Génial Merci Jean !

Bonjour !
Je n'arrive plus à faire fonctionner lilypond-book-preamble.ly avec la version "2.23.9"...
J'ai essayé avec convert-ly mais rien y fait non plus!

%\version "2.22.2"
\version "2.23.9"

\include "lilypond-book-preamble.ly"
%#(ly:set-option 'aux-files #f)

\score {
\new Staff { c1 }

}

Oui, c'est un truc qui traîne…

https://gitlab.com/lilypond/lilypond/-/issues/6235

Il faut rajouter

#(ly:set-option 'tall-page-formats 'eps,png,pdf)
#(ly:set-option 'separate-page-formats 'eps,png,pdf)

Cordialement,
Jean

···

Le jeudi 9 juin 2022, 20:46:29 UTC+2, Jean Abou Samra <****@****> a écrit :
Le 09/06/2022 à 13:37, Ya Gloops a écrit :