Nouveau problème après la mise à jour de java open-jdk-6

Bonjour,

Un problème récurent, il s'était déjà produit chez plusieurs utilisateurs
d'Ubuntu l'année dernière.
Je suis sous Ubuntu 12.04. Lilypond 2.16. Je travaille avec jEdit et
lilypondtool.

Avant hier une mise à niveau est effectuée java open-jdk-6
(6b24-1.11.4-1ubuntu0.12.04.1) au lieu de 6b24-1.11.3-1ubuntu0.12.04.1.

Lilypond ne fonctionne plus depuis, impossible de compiler. Message :
"Cannot run program \lilypond" (in directory \home\....) :
Java.io.IOException : error=2, no such a file or directory"
J'ai tenté de changer la configuration de java (sudo update-alternatives
--config java). Mais il n'y avait pas d'alternatives à la nouvelle version.

J'ai commencé à m'embrouiller en tentant d'installer une version de
sun-java, c'est ce qui marchait, mais n'étant plus présente dans les dépôts
officiels, il a fallu faire autrement. Aucune des solutions que j'ai tentée
n'a donné de bon résultats.
J'ai désinstallé jEdit, réinstallé depuis les dépôts, puis depuis le site de
jEdit. Rien ne fonctionne.

J'ai désinstallé jEdit et voilà où j'en suis avec Java :
Il existe 3 choix pour l'alternative java (qui fournit /usr/bin/java):

* 0 /usr/lib/jvm/java-8-oracle/jre/bin/java 1062
mode automatique
  1 /usr/lib/jvm/java-6-openjdk-i386/jre/bin/java 1061
mode manuel
  2 /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java 1051
mode manuel
  3 /usr/lib/jvm/java-8-oracle/jre/bin/java 1062
mode manuel

Si quelqu'un peut m'aider à sortir de cet imbroglio et remettre de l'ordre
dans tout cela, je lui en serais très reconnaissant.

Gilles Tiar

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Nouveau-probleme-apres-la-mise-a-jour-de-java-open-jdk-6-tp7578364.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.