probleme update syntax

Bonjour a tous!
je suis un nouvel utilisateur de Lilipond et je sens que j'aurai beaucoup de plaisir à l'utiliser. j'espere que je deviendrai rapidement a l'aise avec le logiciel et que je pourrai aider d'autres utilisateurs.

j'ai un probleme : lorsque j'utilise la commande Update syntax, j'obtiens le message suivant

Python 2.4 or newer is required to run this program.

Please upgrade Python from http://python.org/download/, and if you use MacOS X,
please read 'Setup for MacOS X' in Application Usage.

j'ai Python 2.6 installé sur MacOS X et j'utilise Lilypond 2.12.2
qu'est-ce qui ne va pas? qu'est-ce que le 'Application Usage' ?
merci!

Simon

Bonjour a tous!

Bonjour,

je suis un nouvel utilisateur de Lilipond et je sens que j'aurai beaucoup de
plaisir à l'utiliser. j'espere que je deviendrai rapidement a l'aise avec le
logiciel et que je pourrai aider d'autres utilisateurs.

C'est ce qui se produit en général :slight_smile:

j'ai un probleme : lorsque j'utilise la commande Update syntax, j'obtiens le
message suivant
Python 2.4 or newer is required to run this program.
Please upgrade Python from http://python.org/download/, and if you use MacOS
X,
please read 'Setup for MacOS X' in Application Usage.

Petite précision : cette commande est destinée à convertir de "vieux"
fichiers LilyPond pour pouvoir les compiler avec la dernière version
(la syntaxe ayant évolué au fil des versions).

j'ai Python 2.6 installé sur MacOS X et j'utilise Lilypond 2.12.2
qu'est-ce qui ne va pas? qu'est-ce que le 'Application Usage' ?

Ceci :

Il existe un problème pour le script convert-ly avec Mac OSX. Le
problème est que Mac inclut (si mes souvenirs sont bons) plusieurs
versions de Python, et celle qui est employée par défaut (2.3) n'est
pas la bonne. Comme l'explique la documentation :

Il va vous falloir aller modifier la première ligne du fichier
convert-ly (Ctrl-Clic sur l'application LilyPond, "contenu du paquet",
etc.) pour y indiquer le chemin de votre Python 2.6.

Cordialement,
Valentin

···

Le 18 mai 2009 23:49, Simon Beaudry <****@****> a écrit :