Syntaxe de la nouvelle version 2.16

Bonjour à tous,

Version 2.16 installée, mais il semble y avoir des problèmes de syntaxe lors
de l'appel des fonctions GUILE.

L'expression suivante ne passe pas, visiblement à cause du #(ly:export
(lilypond-version))

\line { \fontsize #-4 \line { "Engraved with LilyPond " #(ly:export
(lilypond-version)) \with-url #"http://www.LilyPond.org" \line { \fontsize
#-1 "http://www.LilyPond.org"} } }

Merci de votre aide,

Jean-François

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Syntaxe-de-la-nouvelle-version-2-16-tp7578312.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

Seventies wrote

L'expression suivante ne passe pas, visiblement à cause du #(ly:export
(lilypond-version))

\line { \fontsize #-4 \line { "Engraved with LilyPond " #(ly:export
(lilypond-version)) \with-url #"http://www.LilyPond.org" \line {
\fontsize #-1 "http://www.LilyPond.org"} } }

Merci de votre aide,

Jean-François

bonjour

ly:export n'est plus valable

/#(string-append "Engraved with LilyPond " (lilypond-version))/ marche!

Eluze

···

--
View this message in context: http://lilypond-french-users.1298960.n2.nabble.com/Syntaxe-de-la-nouvelle-version-2-16-tp7578312p7578313.html
Sent from the LilyPond French Users mailing list archive at Nabble.com.

ly:export n'existe plus.
au lieu de :
   #(ly:export (lilypond-version))
il faut mettre :
   $(lilypond-version)
(c'est plus leger)

Est-ce que convert-ly.py le transforme automatiquement ?

Gilles

···

Le Sun, 26 Aug 2012 17:32:54 +0200, Seventies <****@****> a écrit:

\line { \fontsize #-4 \line { "Engraved with LilyPond " #(ly:export
(lilypond-version)) \with-url #"http://www.LilyPond.org" \line { \fontsize
#-1 "http://www.LilyPond.org"} } }

ly:export n'existe plus.

AH ! Désolé, je n'avais pas vu qu'il y avait déjà des reponses...

Gilles